ERROR_CALLBACK: patch fail - Page 2 - Technical Support - WarpPortal Community Forums

Jump to content


Photo

ERROR_CALLBACK: patch fail


  • Please log in to reply
42 replies to this topic

#26 EmmaSOS

EmmaSOS

    I made it Off Topic

  • Members
  • 12 posts

Posted 12 September 2013 - 06:42 PM

and in your ragnarok 2 folder, find the file name version.dat

 

open it with notepad ...

 

change with this format......   UserGameVersion=00000068

                                                  UserPatchVersion=00000068

 

save it and start the client... 

 

Those links are all for the 0000068.RTP ._____.


  • 0

#27 hunterxros

hunterxros

    Amateur Blogger

  • Members
  • 113 posts
  • LocationChannel 3, Alberta
  • Playing:Ragnarok Online 2
  • Server:Freyja

Posted 12 September 2013 - 06:48 PM

Those links are all for the 0000068.RTP ._____.

 

I put all 62 to 68.rtp file to the patch folder of my ro2 folder.. and i change the version.dat like my post a minute ago.. 

 

and then after I click the client... it worked well with no patching again


  • 0

#28 EmmaSOS

EmmaSOS

    I made it Off Topic

  • Members
  • 12 posts

Posted 12 September 2013 - 06:58 PM

I put all 62 to 68.rtp file to the patch folder of my ro2 folder.. and i change the version.dat like my post a minute ago.. 

 

and then after I click the client... it worked well with no patching again

 

so i need to download them even if they have the same name and the same size ._.?

 

PD: how can i open the "VERSION.DAT" file from the RO folder (this is because everyone is saying they opened it with notepad... but i can't.... how do you chaged that file?


Edited by EmmaSOS, 12 September 2013 - 07:00 PM.

  • 0

#29 hunterxros

hunterxros

    Amateur Blogger

  • Members
  • 113 posts
  • LocationChannel 3, Alberta
  • Playing:Ragnarok Online 2
  • Server:Freyja

Posted 12 September 2013 - 07:11 PM

so i need to download them even if they have the same name and the same size ._.?

 

PD: how can i open the "VERSION.DAT" file from the RO folder (this is because everyone is saying they opened it with notepad... but i can't.... how do you chaged that file?

 

 

it has different file name and size

 

 

If you already download the 9/11 manual patch ( 62 to 64.rtp) use it.. (if not start to download it because it has 1.8gig in size...  ) then download the 65 to 68.rtp.. ( it has 120mb in size in total, im not sure)

If you download all the file, put it in patch folder inside ro2 folder..

 

In version.dat= right click then click "open with" then choose the notepad application


Edited by hunterxros, 12 September 2013 - 07:12 PM.

  • 0

#30 EmmaSOS

EmmaSOS

    I made it Off Topic

  • Members
  • 12 posts

Posted 12 September 2013 - 07:13 PM

it has different file name and size

 

 

If you already download the 9/11 manual patch ( 62 to 64.rtp) use it.. (if not start to download it because it has 1.8gig in size...  ) then download the 65 to 68.rtp.. ( it has 120mb in size in total, im not sure)

If you download all the file, put it in patch folder inside ro2 folder..

 

In version.dat= right click then click "open with" then choose the notepad application

 

That's my problem... i right click in it... but there's no "open with"


  • 0

#31 hunterxros

hunterxros

    Amateur Blogger

  • Members
  • 113 posts
  • LocationChannel 3, Alberta
  • Playing:Ragnarok Online 2
  • Server:Freyja

Posted 12 September 2013 - 07:15 PM

That's my problem... i right click in it... but there's no "open with"

 

try double clicking the file


  • 0

#32 EmmaSOS

EmmaSOS

    I made it Off Topic

  • Members
  • 12 posts

Posted 12 September 2013 - 07:19 PM

try double clicking the file

 

that does not work.

 

 

 

 

i open it!! YES!!!

 

i opened the notepad first intead of right clicking it.


Edited by EmmaSOS, 12 September 2013 - 07:20 PM.

  • 0

#33 EmmaSOS

EmmaSOS

    I made it Off Topic

  • Members
  • 12 posts

Posted 12 September 2013 - 07:25 PM

and in your ragnarok 2 folder, find the file name version.dat

 

open it with notepad ...

 

change with this format......   UserGameVersion=00000068

                                                  UserPatchVersion=00000068

 

save it and start the client... 

 

 

I DID IT!!! YES YES!!! I FREAKIN LOVE YOU!!! THANKS THANKS!!!

 

I CHANGED THE FILE FROM 000000062 TO 000000068 THEN STARTED RUNNING THE PATCH AGAIN AND IT WORKED!!!


  • 0

#34 hunterxros

hunterxros

    Amateur Blogger

  • Members
  • 113 posts
  • LocationChannel 3, Alberta
  • Playing:Ragnarok Online 2
  • Server:Freyja

Posted 12 September 2013 - 07:39 PM

I DID IT!!! YES YES!!! I FREAKIN LOVE YOU!!! THANKS THANKS!!!

 

I CHANGED THE FILE FROM 000000062 TO 000000068 THEN STARTED RUNNING THE PATCH AGAIN AND IT WORKED!!!

 

Nice! congrats... I hope no more error in your patching..

 

I have little advice... if error_callback: patch failed Strike again.. dont close it yet..

 

go to your Ragnarok 2 Folder>patch folder then copy all the file inside and place to another place to have backup of your patch... 

 

close the client.. put again your rtp file that you copied in the patch folder again.. then change again the version.dat to 68

 

and run again your client..


  • 0

#35 EmmaSOS

EmmaSOS

    I made it Off Topic

  • Members
  • 12 posts

Posted 12 September 2013 - 07:45 PM

Nice! congrats... I hope no more error in your patching..

 

I have little advice... if error_callback: patch failed Strike again.. dont close it yet..

 

go to your Ragnarok 2 Folder>patch folder then copy all the file inside and place to another place to have backup of your patch... 

 

close the client.. put again your rtp file that you copied in the patch folder again.. then change again the version.dat to 68

 

and run again your client..

 

I have another problem:

 

I start the game and everything works fine in "ID section" and "Second Password Section" but when i'm choosing the "Server and Channel" and click on "start game" then the game does not respond anymore, all i can see is a black screen until the game closes itself


Edited by EmmaSOS, 12 September 2013 - 07:53 PM.

  • 1

#36 hunterxros

hunterxros

    Amateur Blogger

  • Members
  • 113 posts
  • LocationChannel 3, Alberta
  • Playing:Ragnarok Online 2
  • Server:Freyja

Posted 12 September 2013 - 08:08 PM

I have another problem:

 

I start the game and everything works fine in "ID section" and "Second Password Section" but when i'm choosing the "Server and Channel" and click on "start game" then the game does not respond anymore, all i can see is a black screen until the game closes itself

 

try to restart the PC


  • 0

#37 EmmaSOS

EmmaSOS

    I made it Off Topic

  • Members
  • 12 posts

Posted 12 September 2013 - 08:28 PM

try to restart the PC

 

i did it... but still not working...

 

 

before starting the game and entering the two passwords. a window with this appear:

 

Failed - PreActorImgLoader

 

i click it twice and the games starts, but then i enter the two passwords, choose for a server and a channel, but the game closes itself.

 

do you know something about that?


Edited by EmmaSOS, 12 September 2013 - 08:28 PM.

  • 1

#38 LadyRava

LadyRava

    Amateur Blogger

  • Members
  • 199 posts
  • Playing:Ragnarok Online 2
  • Server:Odin

Posted 13 September 2013 - 05:17 AM

I DID IT!!! YES YES!!! I FREAKIN LOVE YOU!!! THANKS THANKS!!!

 

I CHANGED THE FILE FROM 000000062 TO 000000068 THEN STARTED RUNNING THE PATCH AGAIN AND IT WORKED!!!

Changing the Version.dat file just tells the game what the latest patch piece you already have installed. So by changing the number to 68 the game thought you had already installed piece 68 and didn't try again, which is why you didn't get a patch error, but you actually didn't complete patching. I was able to run my game by doing that, but I was missing anything in piece 68. I finally had to reinstall the entire game to fix the problem, but that apparently doesn't work for everyone.


  • 0

#39 Joemid

Joemid

    I am New.

  • Members
  • 4 posts

Posted 18 September 2013 - 10:51 AM

i did it... but still not working...

 

 

before starting the game and entering the two passwords. a window with this appear:

 

Failed - PreActorImgLoader

 

i click it twice and the games starts, but then i enter the two passwords, choose for a server and a channel, but the game closes itself.

 

do you know something about that?

 

I had the same exact problem as you. I got to download the 69.RTP file but my game crashes when I select a character or try to create a character. Also, the PreActorImgLoader error.

I'll try something, and if it does work, I'll tell ya! :3


  • 0

#40 Pichivoice

Pichivoice

    I am New.

  • Members
  • 6 posts

Posted 18 September 2013 - 06:03 PM

For everyone having the ERROR_CALLBACK problem :

 

I copied the RTP files somewhere else when the error happened, then I copied them back into the PATCHES folder.

 

Then I put them in READ ONLY and started the patcher. And it finally worked, though the patching was slow as hell.

 

When it's all done, don't forget to empty our patches folder cause the patcher won't be able to do it since the files are read only.

 

 

If it works for you please spread the word.

I've been stuck with 63 to 69 but now it's all good and I can play the game.

 


  • 0

#41 rioderhoch

rioderhoch

    I am New.

  • Members
  • 1 posts

Posted 19 September 2013 - 08:32 AM

hi guys ..

I have a problem when upgrading the patch.
when it reaches 90% is displayed the message "ERROR_CALLBACK: Patch Fail", after that not more updates.
 
already tried to download the file "00000069.rtp" no more manually operated.
 

  • 0

#42 nathanzay

nathanzay

    I am New.

  • Members
  • 1 posts

Posted 22 September 2013 - 04:29 AM

hello,

 

im getting this error at 50% at patching 0000069.RPT

 

9vb6pdgo.jpg

 

someone here, who can help me fixing this error ?

 

thx


  • 0

#43 Pichivoice

Pichivoice

    I am New.

  • Members
  • 6 posts

Posted 22 September 2013 - 02:38 PM

I don't know if it will work for you, but try this :

 

When you get the error_callback, don't press the OK the button. Go to your installation folder. In there you should find a folder named PATCHES. It should contain the 00000069.rtp file. Right-click on it and select Properties, then click Read-only and then apply. Go click on the ok button on the error_callback window and then the launcher should close. Verify that the files are still there in the patches folder. If yes, then run the launcher again. The patch should install properly this time. Once it's done go back to the patches folder and delete those RTP files.

 

It worked for me, I did it with patches 63 to 69.


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users