Fix for Dragon Saga (I/N) has stopped working! - Technical Support - WarpPortal Community Forums

Jump to content


Photo

Fix for Dragon Saga (I/N) has stopped working!


  • Please log in to reply
21 replies to this topic

#1 N0R13G4

N0R13G4

    I am New.

  • Members
  • 3 posts

Posted 14 June 2011 - 04:50 AM

Well I was messing around with gateway yesterday and got the gateway is not responding error message similar to the one that you get with the game.exe but it popped up a balloon that said data execution prevention has blocked this program from running or something like that. So it sparked my curiosity giving that I've seen this happen with other games in the past and it did in fact end up being just a script flaw that causes DEP to catch it. Well I've been uninstalling/reinstalling, redownloading/patching for 2 days and kinda got tired of it. So figured I would try something different went into the dep settings and added dragonsaga.exe to the exception list and low and behold it ran just fine straight from the patcher, straight from the install folder you name it.

How you do this is
Hit Start
Right click Computer
Click properties
In the left pane click advanced system settings
-under the advanced tab in the performance box click the settings button
-go to the Data Execution Prevention tab
-click the bullet next to "Turn on DEP for all programs and services except those I select:"
-click add browse to your dragon saga install folder, go to the release folder and add dragonsaga.exe

Yes I'm on a vista machine and from all the posts dating back to the start of this problem seems to be where they are happening and most likely the same reason for 7 if there are similar problems. This is a temporary fix yes but works like a charm none the less and points to the source of the problem. Which I would believe to be a script flaw likely in the dragonsaga.exe file itself where the patcher always works regardless. This same thing happened to me with dragon age: origins one time and this is how i fixed it. To beat it all I'm still running both my Comodo firewall and Avira antivirus, nor did I set dragon saga to run for xp sp2 compat runs just like it should. If you want to know what dep actually does check out this link.

DEP kb

So more or less when the executable is opened it is attempting to access a protected zone and is thus shot down. Not sure why it would do this, I'm no programmer or anything just technically savvy. But check it out for yourself I've done about everything I could think of trying to get this to work from these forums. Hope this helps some people get to play and our devs to trudge their way to the heart of the problem.

Edited by N0R13G4, 14 June 2011 - 04:51 AM.

  • 0

#2 Nolanvoid

Nolanvoid

    Nolan Smash!

  • Banned
  • 2024 posts
  • Playing:Dragon Saga

Posted 14 June 2011 - 09:41 AM

Thanks for the input.
  • 0

#3 N0R13G4

N0R13G4

    I am New.

  • Members
  • 3 posts

Posted 14 June 2011 - 01:41 PM

No problem man hopefully will help some people out been trudgin through forums for days lol
  • 0

#4 fwakers

fwakers

    I am New.

  • Members
  • 1 posts

Posted 19 June 2011 - 03:11 PM

i have the same message that doesnt allow me to play the game too, i tried your fix and it didnt work =(
  • 0

#5 BellaMuerte

BellaMuerte

    I made it Off Topic

  • Members
  • 29 posts
  • Playing:Dragon Saga

Posted 27 June 2011 - 12:57 PM

I tried this..and after restarting as I was prompt the window did pop up but it stop responding and never loaded..when I tried again I get the I/N error..
I'm also running on vista (32 bit). :mellow:
I've uninstalled and reinstalled so many times I lost count..I even tried the 2 part download but it won't unzip after I download both parts.

Edited by BellaMuerte, 27 June 2011 - 12:58 PM.

  • 0

#6 Nolanvoid

Nolanvoid

    Nolan Smash!

  • Banned
  • 2024 posts
  • Playing:Dragon Saga

Posted 27 June 2011 - 01:30 PM

Do you have the latest version of WinRAR and do you have it in its own folder?
  • 0

#7 BellaMuerte

BellaMuerte

    I made it Off Topic

  • Members
  • 29 posts
  • Playing:Dragon Saga

Posted 27 June 2011 - 03:06 PM

I don't use WinRAR I use peazip..does it make a difference?
And yes I had downloaded the two parts into it's own folder. But it wouldn't let me extract the first part I basically just kept getting an error.
  • 0

#8 Nolanvoid

Nolanvoid

    Nolan Smash!

  • Banned
  • 2024 posts
  • Playing:Dragon Saga

Posted 27 June 2011 - 03:37 PM

It may, I can't say for sure as I haven't used peazip. I'd personally use the same program for continuity purposes.
  • 0

#9 N0R13G4

N0R13G4

    I am New.

  • Members
  • 3 posts

Posted 29 June 2011 - 12:04 AM

I downloaded it by torrent at http://bt.mmosite.com/stats.php?bid=71

You should double check that your firewall and or antivirus has an exception added for the dragonsaga.exe although i don't really think its that big of a thing as avira and comodo both weren't trying to block it for me anyway. Biggest thing I've seen is just having all the visual c++ updates I ended up having a c++ 2008 security update that I was missing and once they were installed was able to take out the dep exception and run it normally. Other than that the only thing I did was run through the registry and check for any thq or dragonica entries and deleted them. But would imagine that it had more to do with the c++ update but could be worth a shot for you if you played the thq ice version of the game. Oh and if you want a good zip program try 7zip its free and good stuff.

Edited by N0R13G4, 29 June 2011 - 12:07 AM.

  • 0

#10 BellaMuerte

BellaMuerte

    I made it Off Topic

  • Members
  • 29 posts
  • Playing:Dragon Saga

Posted 29 June 2011 - 02:27 PM

I may try the torrent download...I'm just so tired of having to uninstall and reinstall it's such a pain. x-x'

But yeah as far as I know my c++ is up to date but I'll check it again. I'm pretty sure I've gotten rid of any Dragonica files I had..but again I'll double check..just irks me that I feel like no matter what I do I still have to fight with it to eventually get on..u-u'
I hope I find something that works soon.
  • 0

#11 WeltallOfId

WeltallOfId

    I made it Off Topic

  • Members
  • 99 posts
  • Playing:Dragon Saga

Posted 06 September 2011 - 12:27 AM

As much as it pains me to say this I found a solution to why my Dragon Saga would randomly crash at either when I pressed Start from the launcher or when I tried to login by inputting my name and password. After sharing my client with a couple of friends and my gf only I had the problem while they never had no problems. It was my Comodo internet security. No matter what I did, be it I put the game in exceptions or turned every options off for it the game would still crash. Even closing Comodo totally from the exit option would do nothing. As soon as the protection software was uninstalled and computer restarted the game would start with no problem anymore. I guess I will rely on Microsoft's internet security for now. Well at least thank God problem solved.

P.S. I tested Avira antivirus and avast and also Privatefirewall and non of them had any problems. I ended up choosing to keep Microsoft Security Essentials and the default Microsoft firewall.

Edited by WeltallOfId, 06 September 2011 - 12:43 AM.

  • 0

#12 Slaqr

Slaqr

    I am New.

  • Members
  • 1 posts

Posted 06 September 2011 - 03:20 PM

As much as it pains me to say this I found a solution to why my Dragon Saga would randomly crash at either when I pressed Start from the launcher or when I tried to login by inputting my name and password. After sharing my client with a couple of friends and my gf only I had the problem while they never had no problems. It was my Comodo internet security. No matter what I did, be it I put the game in exceptions or turned every options off for it the game would still crash. Even closing Comodo totally from the exit option would do nothing. As soon as the protection software was uninstalled and computer restarted the game would start with no problem anymore. I guess I will rely on Microsoft's internet security for now. Well at least thank God problem solved.

P.S. I tested Avira antivirus and avast and also Privatefirewall and non of them had any problems. I ended up choosing to keep Microsoft Security Essentials and the default Microsoft firewall.


I second this solution; I kept getting the "Dragon Saga (I/N) has stopped working!"-error, but after unstalling the Comodo security suite, the game works fine.
  • 0

#13 ManojZK

ManojZK

    I am New.

  • Members
  • 1 posts

Posted 16 January 2012 - 06:41 AM

Doesn't work for me. Still getting the same damn error and i don't have Comodo installed.

Edited by ManojZK, 16 January 2012 - 06:51 AM.

  • 0

#14 janusyuki

janusyuki

    I am New.

  • Members
  • 2 posts

Posted 19 January 2012 - 07:09 AM

Heya, I've been going through all threads of the forums for a fix for the "Dragon Saga (I/N)" problem and none of the stuff I tried have worked.
I've tried the DEP thing, clean reinstall of the entire game with deleting all Dragon Saga related files and download a new install file, also tried deleting the "Patch.id" file and repatched 3-4 times but nothing seems to fix it.

Sometimes when I go into the release folder and click the main DragonSaga.exe file to start the game without going through the patcher client, the game will start with no problems once in a while.
There comes my next problem, I write in my login info and click login and the client crashes with same error or no error message at all. To get the game to start I have to keep clicking the DragonSaga.exe file over and over until the game somehow starts and I can play for a little time but if I get random crash I have to do the process all over again and hope I get past the login screen again.

I've tried turning off my ZoneAlarm firewall and Avast antivirus, made exclusions for the DragonSaga.exe in both of them.
I've also tried running the game in different compatibility modes, Windows XP service Pack 1-2, Vista SP 1-2. Also running the game with Admin rights.
I have even reinstalled fresh install of Java, Adobe Flashplayer, updated my graphic card drivers etc etc but nothing seem to work.

I hope that someone got something new I can tryout that hopefully fixes my problem.
I'm running on Windows 7 64bit.

Edited by janusyuki, 19 January 2012 - 07:11 AM.

  • 0

#15 Nenenesan

Nenenesan

    I made it Off Topic

  • Members
  • 47 posts
  • Playing:Dragon Saga

Posted 08 February 2012 - 02:55 PM

This is a frustrating problem.

I managed to make it works somehow.

If you have a c0000005 error code from your windows, thats mean a program from your computer block the dragonsaga apps to work.

Go through the DEP mentioned above. Check your windows defender, firewall, antivirus. Make sure that you make exclusion to the entire dragonsaga folder files.

If you are using COMODO: DEFENSE+ >> TRUSTED FILES >> ADD >> (browse to your dragonsaga folder and add ..\release\dragonsaga.exe or just add the entire folder)

other antivirus, well check your manual. goodluck
  • 0

#16 WeltallOfId

WeltallOfId

    I made it Off Topic

  • Members
  • 99 posts
  • Playing:Dragon Saga

Posted 19 March 2012 - 06:34 PM

Well seems it doesn't like the new version of Avast either. On my desktop that I have the old version of avast I never had a problem, I updated on my laptop and i/n error keeps popping. Uninstalled Avast and worked like it used to, like a charm.
  • 0

#17 Kyiro

Kyiro

    I am New.

  • Members
  • 5 posts

Posted 21 March 2012 - 09:59 PM

Well seems it doesn't like the new version of Avast either. On my desktop that I have the old version of avast I never had a problem, I updated on my laptop and i/n error keeps popping. Uninstalled Avast and worked like it used to, like a charm.



You're exactly right...well for my issue anyway. I've been having the same problems. so since I do use avast, I tried experimenting. I simply turned off all my shields with avast still on the computer and it started the game just fine. One of my friends on my vent suggested that it may only be 1 shield rather than all of them and he was right. I disabled Avast's script shield and it started working perfectly. So for those of you who use avast, you can give this a try. Hopefully it will work for you.
  • 0

#18 MayCappel

MayCappel

    I am New.

  • Members
  • 3 posts

Posted 22 March 2012 - 03:38 AM

sry but im posting in all fourums related to bug of DS could u help me figure out what mss32 is and how to get rid of the pein invisible walls imn actualy tierd of having to delete this install this bla bla bla i just wana play normoly :( think u could help me
  • 0

#19 MasterKoo

MasterKoo

    I am New.

  • Members
  • 1 posts

Posted 19 April 2012 - 04:06 AM

I'm also using Comodo Internet Security and I've been able to get Dragon Saga working now without having to uninstall Comodo.

Dragon Saga started to work perfectly as soon as I went to the "Defence+" menu, went into "Computer Security Policy", and added the "...\release\dragonsaga.exe" file under the "Defence+ Rules" tab.

Initially I also tried deleting the whole Comodo thing and yes the game worked fine. Then I installed Comodo again and the game wouldn't open, even with all options disabled like Defence+ and Firewall, etc.

I added the "whole dragon saga folder" to "Trusted Files" under the "Defence+" menu... didn't work.
Added the "dragonsaga.exe" file into "Define a New Trusted Application" under the "Firewall" menu... didn't work.
Then, as mentioned in the beginning, when I added "dragonsaga.exe" into "Computer Security Policy (Defence+ Rules tab)" under the "Defence+" menu... game started working fine.
  • 0

#20 Dannyh3144

Dannyh3144

    I am New.

  • Members
  • 4 posts

Posted 05 May 2012 - 08:34 AM

I am trying to add dragonSaga to system properties but idk where the actual game is in my computer!
  • 0

#21 Spold

Spold

    I made it Off Topic

  • Members
  • 26 posts

Posted 22 March 2013 - 07:23 PM

Sorry for the necro, but I'm new and this doesn't work for me.

It goes like this.

A gray, black, or white window appears, and the window automatically closes within five seconds of being activated. The log in screen isn't even shown.
  • 0

#22 blackhunter

blackhunter

    I am New.

  • Members
  • 2 posts

Posted 20 April 2013 - 07:39 AM

Doesn't work for me. Still getting the same error... Help MEE!!
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users