How to fix the "failed to connect to patch server" error - Page 2 - Technical Support/Bug Reporting - WarpPortal Community Forums

Jump to content


Photo
* * * * * 1 votes

How to fix the "failed to connect to patch server" error


  • This topic is locked This topic is locked
60 replies to this topic

#26 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 11 November 2013 - 09:41 AM

Hi, thank you for creating this thread, but I am unable to fix the problem even after going through the steps.

 

I am attempting to connect through steam, and usually I have to attempt it about 3-4 times until it connects, and it usually successfully connects, but now it simply will not. Nothing changed from today and yesterday when I was able to play. It simply repeats the message "Failed to connect to patch server" once the patcher opens.

 

I went through your steps, I am able to SUCCESFULLY connect in internet explorer to those files in the link you provided, and am UNSUCCESSFUL in connecting with Chrome or Firefox.

I tried flushing the DNS, disabling the firewall temporarily, and restarting my router. I am still unable to.

I am attempting to connect from my home. WIndows 7 Home Premium. A PC. My router is cisco model 157082028. My ISP is comcast. I've tried opening the executables directly from the steam folder, no difference.

 

I'd really appreciate some help. Thank you for your time.

 

Are you still experiencing this problem? I'm hoping it has resolved itself because I have no idea what could cause the FTP server to be accessible in Internet Explorer but not other applications.  :blink:


  • 0

#27 ImYoungxD

ImYoungxD

    I am New.

  • Members
  • 1 posts

Posted 23 November 2013 - 04:29 PM

I couldn't patch my game and internet explorer and firefox was loading the patch. I ran the game as administrator and it patched up.


  • 0

#28 ayana92

ayana92

    I made it Off Topic

  • Members
  • 77 posts
  • Playing:Ragnarok Online
  • Server:Classic

Posted 08 January 2014 - 03:09 PM

*edit* Seems the ports got closed to play Ro..so problem fixed


Edited by ayana92, 13 January 2014 - 10:03 PM.

  • 0

#29 Darkwolf93

Darkwolf93

    I am New.

  • Members
  • 9 posts
  • Playing:Nothing

Posted 11 January 2014 - 02:30 PM

In response to the original post - 

 

Thank you so much!  It has been over a year (or at least half a year) since I last played RO.  I recently got an iMac with Parallels and Windows 8, after finally getting RO installed and everything the darn patcher wouldn't work!  Loading the ftp://patch1.playragnarok.com/ link worked for me.

However, now I have a new problem... "Cannot init d3d OR grf file has problem." 

It seems like the problems never end.  Oh well, off to search for a fix for this issue as well, just wanted to say thanks for resolving my first issue :)

 

~Tora Kuroichi


Edited by Darkwolf93, 11 January 2014 - 02:33 PM.

  • 0

#30 RenLynn

RenLynn

    I am New.

  • Members
  • 4 posts
  • Playing:Ragnarok Online
  • Server:Thor

Posted 03 February 2014 - 05:10 AM

So I've done everything multiple times only in the end to get a pop-up error message that reads: "Failed to connect to file server."

I'm not sure what to do after that. :/


  • 0

#31 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 03 February 2014 - 05:26 AM

So I've done everything multiple times only in the end to get a pop-up error message that reads: "Failed to connect to file server."
I'm not sure what to do after that. :/


Please follow the instructions in this post.
  • 0

#32 RenLynn

RenLynn

    I am New.

  • Members
  • 4 posts
  • Playing:Ragnarok Online
  • Server:Thor

Posted 04 February 2014 - 01:59 PM

Please follow the instructions in this post.

 

Microsoft Windows [Version 6.0.6002]
Copyright © 2006 Microsoft Corporation.  All rights reserved.

C:\Windows\system32>ftp -A patch1.playragnarok.com
Connected to patch.1.online.ragnarok.warpportal.net.
220 Ragnarok Online Patch Server
331 Anonymous access allowed, send identity (e-mail name) as password.
230-Welcome to the WarpPortal Ragnarok Online Patch Service
    Directory has 143,664,074,752 bytes of disk space available.
230 User logged in.
Anonymous login succeeded for Maverek@Castiel-PC
ftp>


Edited by RenLynn, 04 February 2014 - 02:00 PM.

  • 0

#33 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 04 February 2014 - 02:07 PM

Microsoft Windows [Version 6.0.6002]
Copyright © 2006 Microsoft Corporation.  All rights reserved.

C:\Windows\system32>ftp -A patch1.playragnarok.com
Connected to patch.1.online.ragnarok.warpportal.net.
220 Ragnarok Online Patch Server
331 Anonymous access allowed, send identity (e-mail name) as password.
230-Welcome to the WarpPortal Ragnarok Online Patch Service
    Directory has 143,664,074,752 bytes of disk space available.
230 User logged in.
Anonymous login succeeded for Maverek@Castiel-PC
ftp>


Do you know how to modify your router's configuration? If so, try temporarily disabling your router's firewall and then test whether the problem still occurs.
  • 0

#34 ilovemilk

ilovemilk

    Too Legit To Quit

  • Members
  • 3451 posts
  • LocationMilky Way
  • Playing:Ragnarok Online
  • Server:Offline

Posted 04 February 2014 - 08:21 PM

I also want to add that one should not run the patcher through wifi. The reason is because a lot of wifi routers block ftp address by default.

Edited by ilovemilk, 04 February 2014 - 08:22 PM.

  • 0

#35 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 05 February 2014 - 05:00 AM

I also want to add that one should not run the patcher through wifi. The reason is because a lot of wifi routers block ftp address by default.


I think you're confusing public Wi-Fi routers with home Wi-Fi routers. If a large proportion of home Wi-Fi routers blocked FTP connections by default, then this section of the forum would be flooded with people complaining they are unable to update their client.
  • 0

#36 ilovemilk

ilovemilk

    Too Legit To Quit

  • Members
  • 3451 posts
  • LocationMilky Way
  • Playing:Ragnarok Online
  • Server:Offline

Posted 05 February 2014 - 11:36 AM

I think you're confusing public Wi-Fi routers with home Wi-Fi routers. If a large proportion of home Wi-Fi routers blocked FTP connections by default, then this section of the forum would be flooded with people complaining they are unable to update their client.

True, but then there are a tiny percent of those who uses a home router that does block ftp site by default. My Asus RT_N66U for example :D.


  • 0

#37 Fforge

Fforge

    I made it Off Topic

  • Members
  • 15 posts

Posted 14 April 2014 - 07:55 PM

i have been having this problem for three days now.. But within those 3 days there are times that i can log in and play.

Sunday evening is when i first encountered the "Failed to connect to patch server" problem. I tried the test mentioned on this post and the result was successful, I was able to access the server using Internet Explorer. But it didn't work, still got the problem.

 

But Monday morning, the patcher completed the patch but when i hit play, i encountered a new problem so i posted this thread:

 

http://forums.warppo...on-a-nil-value/

 

After resolving this problem, i was able to play again and logged out in the afternoon. However, at Monday night, i got the "Failed to connect to patch server" problem again. I just ignored my frustration and went to bed.

 

This morning (Tuesday morning), I was able to log in and played but i got to eat lunch so i logged out at lunch time.  After an hour when i tried to log in again, i got the "Failed to connect to patch server" problem again. I tried the test again and was successful but still have the problem.

 

This is getting frustrating. Please help me.


  • 0

#38 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 14 April 2014 - 09:04 PM



i have been having this problem for three days now.. But within those 3 days there are times that i can log in and play.

Sunday evening is when i first encountered the "Failed to connect to patch server" problem. I tried the test mentioned on this post and the result was successful, I was able to access the server using Internet Explorer. But it didn't work, still got the problem.

 

But Monday morning, the patcher completed the patch but when i hit play, i encountered a new problem so i posted this thread:

 

http://forums.warppo...on-a-nil-value/

 

After resolving this problem, i was able to play again and logged out in the afternoon. However, at Monday night, i got the "Failed to connect to patch server" problem again. I just ignored my frustration and went to bed.

 

This morning (Tuesday morning), I was able to log in and played but i got to eat lunch so i logged out at lunch time.  After an hour when i tried to log in again, i got the "Failed to connect to patch server" problem again. I tried the test again and was successful but still have the problem.

 

This is getting frustrating. Please help me.

 

If you're able to update your client sometimes but not always, then the problem is probably related to DNS. Try adding the address of the update server to your hosts file.


  • 0

#39 Fforge

Fforge

    I made it Off Topic

  • Members
  • 15 posts

Posted 14 April 2014 - 11:11 PM

oh wow.. thanks sir!

 

your very good at this. i can play now..  :heh:  :heh:  :thx:  :thx:

 

but do we know if the addresses of the domains have changed?


Edited by Fforge, 14 April 2014 - 11:15 PM.

  • 0

#40 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 15 April 2014 - 01:57 AM



oh wow.. thanks sir!

 

your very good at this. i can play now..  :heh:  :heh:  :thx:  :thx:

 

but do we know if the addresses of the domains have changed?

 

You'll know if the addresses have changed because you'll be unable to update your client or connect to playragnarok.com. However, it's very rare for this to happen; I think it has only happened once in the last 11 years, when Gravity switched to a different ISP.


  • 0

#41 3116131211165816037

3116131211165816037

    I made it Off Topic

  • Members
  • 53 posts
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 05 June 2014 - 10:39 PM

Microsoft Windows [Version 6.1.7601]
Copyright © 2009 Microsoft Corporation.  All rights reserved.
 
C:\Users\A>ftp -A patch1.playragnarok.com
Connected to patch.1.online.ragnarok.warpportal.net.
220 Ragnarok Online Patch Server
331 Anonymous access allowed, send identity (e-mail name) as password.
230-Welcome to the WarpPortal Ragnarok Online Patch Service
    Directory has 143,454,425,088 bytes of disk space available.
230 User logged in.
Anonymous login succeeded for A@A-PC
ftp>

  • 0

#42 AeroKrauger

AeroKrauger

    Amateur Blogger

  • Members
  • 346 posts
  • LocationIndonesia
  • Playing:Ragnarok Online
  • Server:Chaos Renewal

Posted 18 June 2014 - 12:53 PM

Guys i have a solution, well i dont know but it fixed my problem in Windows XP. open your Internet Explorer click Tools > Internet Options > Connection Tab > Lan Settings > UNCHECK/UNMARK EVERYTHING then click on OK. then go to Advanced Tab click on Restore Defaults. it should work. it worked for me :D . Oh yea i uninstalled Hola Unblocker too. i used Hola Unblocker to play Ragnarok Valkyrie Uprising in Facebook.


  • 1

#43 grainofsong

grainofsong

    I am New.

  • Members
  • 6 posts

Posted 21 July 2014 - 12:43 PM

Nice catch with Hola! Turning it off let me patch--I was getting 403s trying to connect to the FTP server through my browsers.


  • 0

#44 juxtapposed

juxtapposed

    Amateur Blogger

  • Members
  • 497 posts
  • LocationHell's Kitchen
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 23 August 2014 - 04:23 AM

After the recent patch (August 20, 2014), whenever I start the client, it downloads all the new files again. And it takes so long for the patch to be completed because the recent update is large.

I just had this problem with the recent patch. 


  • 0

#45 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 23 August 2014 - 10:45 AM

After the recent patch (August 20, 2014), whenever I start the client, it downloads all the new files again. And it takes so long for the patch to be completed because the recent update is large.

I just had this problem with the recent patch.


How is your question related to the topic of this thread? :P

Try following the instructions in this post.
  • 0

#46 2541130501212216570

2541130501212216570

    I made it Off Topic

  • Members
  • 11 posts

Posted 07 October 2014 - 02:23 AM

i did everything this told me to do. still nothing please help me


  • 0

#47 2541130501212216570

2541130501212216570

    I made it Off Topic

  • Members
  • 11 posts

Posted 07 October 2014 - 02:28 AM

Guys i have a solution, well i dont know but it fixed my problem in Windows XP. open your Internet Explorer click Tools > Internet Options > Connection Tab > Lan Settings > UNCHECK/UNMARK EVERYTHING then click on OK. then go to Advanced Tab click on Restore Defaults. it should work. it worked for me :D . Oh yea i uninstalled Hola Unblocker too. i used Hola Unblocker to play Ragnarok Valkyrie Uprising in Facebook.

that didn't work...at all


  • 0

#48 Exuro

Exuro

    Too Legit To Quit

  • Members
  • 3260 posts
  • Playing:Ragnarok Online
  • Server:Chaos Renewal, RE:START

Posted 07 October 2014 - 03:01 AM

This always happens to me. Well, not always (all I won't be playing lol). The thing is, 90% of the time, I always fail to connect to the patch server. What I do is I just restart and restart my patch client until it goes through. It's like I'm trying to pin the tail on the donkey.

 

Ohwell, I got used to it anyway. :P


  • 0

#49 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 27 October 2014 - 12:31 PM

i did everything this told me to do. still nothing please help me


Please describe the problem you're having. Unless it's identical to the problem described here, put this in a new thread; There are a lot of causes of patch problems that can look very similar, and it's imperative that we know what exact issue you're having, because all these patch problems require different solutions, and trying solutions to the wrong problem can cause more harm than good.
  • 0

#50 WolfTri

WolfTri

    Too Legit To Quit

  • Members
  • 1907 posts
  • LocationWinterfell
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 26 November 2014 - 05:13 PM

Hey, so I'm able to access the update server on both IE as well as chrome. My iRO renewal client is working just fine, but both my classic RO and sakray clients are hanging up, as in not responding, at the patch_allow.txt stage. It just shows that, the full green bar, and then stops responding. I've had the problem for a while now, and it works very rarely after restarting the client several times (10+).


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users