How to fix the "failed to connect to patch server" error - Page 3 - Technical Support/Bug Reporting - WarpPortal Community Forums

Jump to content


Photo
* * * * * 1 votes

How to fix the "failed to connect to patch server" error


  • This topic is locked This topic is locked
60 replies to this topic

#51 eufonia

eufonia

    I am New.

  • Members
  • 1 posts

Posted 19 December 2014 - 07:35 AM

does anyone have latest client download link to torrent? i've done all the steps but nothing  works

this is so frustating. i want to try re-install. help please


Edited by eufonia, 19 December 2014 - 07:49 AM.

  • 0

#52 JorgeMaster

JorgeMaster

    I made it Off Topic

  • Members
  • 12 posts
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 17 January 2015 - 06:27 PM

Was playing normally during the day, when I open the patch again began updating since 2011! I waited after a long time and now happens "Failed To Connect To Server."

I could not solve my problem, I did all the steps mentioned

:p_sad:


  • 0

#53 WolfTri

WolfTri

    Too Legit To Quit

  • Members
  • 1939 posts
  • LocationWinterfell
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 29 January 2015 - 05:14 AM

Unable to connect via both IE and Chrome, tried all the steps to fix internet connection, to no avail. 

Logging in from home.

Router model : SpeedSurf 504 AN

 

Been having such problems for a while now, it worked for a while after flushing DNS, isn't working anymore.


  • 0

#54 NheytanSy

NheytanSy

    I am New.

  • Members
  • 2 posts

Posted 19 February 2015 - 12:41 AM

Please help, im having this error message :(

 


  • 0

#55 Garm1

Garm1

    I made it Off Topic

  • Members
  • 23 posts

Posted 04 March 2015 - 08:13 PM

I tried everything in the OP and I restarted my computer. I got in once and the game was super laggy for some reason then I got booted. I can get to the servers but when I try to get to the character selection its the usual "failed to connect to server."


  • 0

#56 arrowspear

arrowspear

    Amateur Blogger

  • Members
  • 149 posts
  • Playing:Ragnarok Online
  • Server:Thor

Posted 18 June 2015 - 06:20 AM

I can access ftp://patch1.playragnarok.com/ through Internet Explorer but not Google Chrome. I am still getting that "Failed to connect to patch server" error when I start RO client.


  • 0

#57 Kuagata

Kuagata

    I am New.

  • Members
  • 9 posts

Posted 06 August 2015 - 01:43 PM

This guide explains how to resolve the "failed to connect to patch server" error.

Note:

  • "Updater" is a synonym for "patch client".
  • You must use Internet Explorer where the instructions specify to because the updater uses it to download updates.
Determining where the problem lies

Test whether you can access the update server using both Internet Explorer and another web browser, such as Chrome, Firefox, or Opera:
  • In Internet Explorer, enter "ftp://patch1.playragnarok.com/" into the address field and then press enter.
  • If you are presented with a list of folders that includes aspnet_client, cpatch, csakpatch, patch, ro2patch, and sakpatch, then the test was successful. Otherwise, it was unsuccessful.
  • If the test was unsuccessful (in Internet Explorer), then repeat steps 1–2 with another web browser.
If you are only unable to access the server using Internet Explorer, then go to the Fixing Internet Explorer section.

If you are unable to access the server using neither Internet Explorer or another web browser, then go to the Fixing your Internet connection section.

If you are able to access the server using Internet Explorer, then test whether the problem has been resolved by opening the IRO client. (Simply accessing the update server using Internet Explorer can sometimes resolve the problem.)

Fixing Internet Explorer

Try each of the following steps in order:
  • Restart your computer.
  • If you have any download managers installed, such as FlashGet, Free Download Manager, or GetRight, then configure them to not integrate with Internet Explorer. (The credit for this advice belongs to Ghen.)
  • Scan for and remove any malware from your computer using software such as Malwarebytes Anti-malware.
  • Reset your Internet Explorer configuration.

    Note: I recommend that you create a backup of your Internet Explorer configuration before doing this. If you are unable to access the Internet or Web after resetting your configuration, then restore the backup.
  • Scan for and repair any corrupted system files.
  • If a newer version of Internet Explorer is available, then upgrade to it.
Fixing your Internet connection

Try each of the following steps in order:
  • Open and close the updater several times (no more than seven times should be necessary).
  • Clear your DNS resolver cache:
    • Open Command Prompt.
    • Enter "ipconfig /flushdns".
  • If you use a third-party firewall, then test whether you can update the IRO client while the firewall is temporarily disabled. If you can, then revise your firewall configuration accordingly. You should also do the same for your router's firewall if it has one.

    Warning: Do not permanently disable your router's firewall because doing so could expose your computer and any other devices on your local area network to threats.
  • Restart your router.
If none of these steps resolve the problem, then please reply to this thread with the following information:
  • The results of completing the test described in the Determining where the problem lies section.
  • Where you are attempting to connect from. (For example, your home.)
  • The manufacturer and model of your router. (Most routers have a label on their base on which this information is printed.)

 

None of this works for me, my problem is recent, the date is 08/06/15, somebody help D:


  • 0

#58 xredkaiser12

xredkaiser12

    I am New.

  • Members
  • 2 posts
  • Playing:Nothing

Posted 01 November 2015 - 05:46 PM

is this thread updating?


  • 0

#59 xredkaiser12

xredkaiser12

    I am New.

  • Members
  • 2 posts
  • Playing:Nothing

Posted 01 November 2015 - 05:51 PM

i follow all the steps provided still having the same error message "cant connect to patch sever"

 

i can access the directory from any browser id use.

 

Microsoft Windows [Version 6.1.7601]
Copyright © 2009 Microsoft Corporation.  All rights reserved.
 
C:\Users\Gravity>ftp -Ad patch1.playragnarok.com
Connected to patch.1.online.ragnarok.warpportal.net.
220 Ragnarok Online Patch Server
---> USER anonymous
331 Anonymous access allowed, send identity (e-mail name) as password.
---> PASS Gravity@E-18
230-Welcome to the WarpPortal Ragnarok Online Patch Service
    Directory has 142,777,794,560 bytes of disk space available.
230 User logged in.
Anonymous login succeeded for Gravity@E-18
ftp>
 
also this my cmd test..
 
 
can anyone help me with this problem???

  • 0

#60 jehzeel

jehzeel

    Amateur Blogger

  • Members
  • 127 posts
  • LocationManila
  • Playing:Ragnarok Online
  • Server:Chaos / New Chaos / Thor

Posted 13 August 2016 - 05:03 AM

For those who are encountering this problem my solution might help. This solution is for those who cannot access ftp://patch1.playragnarok.com/ in their browser.

 

What I did was I pinged patch1.playragnarok.com via ping.eu to get its IP, as I cannot ping it directly using my command window. I also cannot access warpportal.com, support.warpportal.com, forums.warpportal.com, and all other warpportal related websites. After I pinged patch1.playragnarok.com and other warp portal subdomains and obtained their IPs, I added them all to my hosts file.

 

Just like this:

128.241.93.57 warpportal.com
128.241.93.57 www.warpportal.com
128.241.93.17 support.warpportal.com
128.241.93.3 forums.warpportal.com
128.241.93.38 patch1.playragnarok.com
 
Then after adding it all, I can now patch and connect to all warpportal sites. :)
 
To know where you hosts file is located, check this post out:

Edited by jehzeel, 13 August 2016 - 05:05 AM.

  • 0

#61 VModCinnamon

VModCinnamon

    Tranquility

  • Senior Warpportal VM
  • 13502 posts
  • Playing:Ragnarok Online

Posted 13 August 2016 - 05:56 AM

Hello,

Thank you for providing a possible solution. Please take a note that it is best to avoid bumping old topics, also 'failed to connect to patch server' has been covered here. You might want to share further new findings in said topic.

 

Locked.


Edited by VModCinnamon, 13 August 2016 - 05:57 AM.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users