How to play Ragnarök Online on Linux - Page 4 - Technical Support/Bug Reporting - WarpPortal Community Forums

Jump to content


Photo
* * * * * 3 votes

How to play Ragnarök Online on Linux


  • Please log in to reply
127 replies to this topic

#76 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 19 March 2016 - 08:52 PM

I got a strange error while running the game in my Ubuntu 14.04. There are some AI related files missing and the game freezes when I enter with my Biochemist. The game works really well with any other classes.

See picture: http://i.imgur.com/viYc85e.jpg

I checked and all those files are really missing, some directories does not even exist, e.g. "C:\Gravity\Ragnarok Online\lua"
Does anyone know what to do?

EDIT: I tried to reinstall it, but was ineffective.


I don't think this is a Wine-specific issue; see item 12 in the thread Common problems and their solutions.

To view the contents of Wine's virtual drive C:
  • Open Files.
  • Press control-L and then enter ~/.wine/drive_c.
If you want to use a custom AI system, then ensure you extract the new files into the AI/USER_AI subfolder, not the AI subfolder.

Edited by Axylus, 20 March 2016 - 12:20 AM.

  • 0

#77 Gabemba

Gabemba

    I am New.

  • Members
  • 4 posts

Posted 20 March 2016 - 03:36 PM

Thanks Axylus!

One of the Default AI System was missing and after replacing them with the originals the problem was solved.


  • 0

#78 dboomhower

dboomhower

    I am New.

  • Members
  • 6 posts

Posted 10 May 2016 - 03:41 AM

Anyone able to get the sound working?

Nevermind, it's working now


Edited by dboomhower, 10 May 2016 - 03:49 AM.

  • 0

#79 MasterOfBytes80

MasterOfBytes80

    I made it Off Topic

  • Members
  • 69 posts
  • LocationGermany
  • Playing:Ragnarok Online
  • Server:Renewal Chaos

Posted 14 June 2016 - 12:42 AM

Hello,

it's me again^^.

 

After thinking several month that it doesn't work, i accidental found out that it works, but i have the folowing problem:

 

The game itself works well and is playable. But, after the loading screen, at 100%, the loading screen doesn't go away. I have to minimize the window and bring it back, then i see the game. At this 100% stage, clicking blindly works and let my char move.

That is at every loading screen and kinda annoying. Anyone may have an idea?


Edited by MasterOfBytes80, 14 June 2016 - 12:43 AM.

  • 0

#80 GargamelSE

GargamelSE

    I am New.

  • Members
  • 4 posts

Posted 19 June 2016 - 01:32 AM

Hi.

I just installed this using PlayOnLinux.

if i have a clean install and start classicRO, it starts.

But if i start renewal/ragnarok.exe, it downloads a bunch of files, and then i get sprite error boxes when launching the game, and then the game just sists there in a black screen (windowed mode) and i have to force quit it.

When the sprite error started on the renewal one, it starts in the classic too.


  • 0

#81 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 19 June 2016 - 03:23 PM

Hi.
I just installed this using PlayOnLinux.
if i have a clean install and start classicRO, it starts.
But if i start renewal/ragnarok.exe, it downloads a bunch of files, and then i get sprite error boxes when launching the game, and then the game just sists there in a black screen (windowed mode) and i have to force quit it.
When the sprite error started on the renewal one, it starts in the classic too.


You shouldn't use PoL because the installation script for RO hasn't been updated since June 2009.
  • 0

#82 GargamelSE

GargamelSE

    I am New.

  • Members
  • 4 posts

Posted 20 June 2016 - 06:58 AM

You shouldn't use PoL because the installation script for RO hasn't been updated since June 2009.

I only used pol, to start the installer, i didnt use any pre-defined scripts it might list. 


  • 0

#83 jawer

jawer

    I am New.

  • Members
  • 6 posts
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 20 June 2016 - 09:38 AM

Hello,

it's me again^^.

 

After thinking several month that it doesn't work, i accidental found out that it works, but i have the folowing problem:

 

The game itself works well and is playable. But, after the loading screen, at 100%, the loading screen doesn't go away. I have to minimize the window and bring it back, then i see the game. At this 100% stage, clicking blindly works and let my char move.

That is at every loading screen and kinda annoying. Anyone may have an idea?

 

This exact same thing happens to me, I installed it using OP's guide on Ubuntu 16.04


  • 0

#84 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 20 June 2016 - 05:37 PM

I only used pol, to start the installer, i didnt use any pre-defined scripts it might list.


In that case, you should install the Visual C++ 2008 Run-Time Library and then reinstall the client. Errors concerning missing resources, such as sprites, will occur if you run the updater without first installing the Visual C++ 2008 Run-Time Library, which will cause the client's main resource file (data.grf) to become corrupted.

This exact same thing happens to me, I installed it using OP's guide on Ubuntu 16.04


Try the following:
  • Open Terminal.
  • Enter the following:

    wine reg add "HKCU\Software\Wine\Direct3D" /v OffscreenRenderingMode /d backbuffer

  • 0

#85 jawer

jawer

    I am New.

  • Members
  • 6 posts
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 21 June 2016 - 02:19 AM

 

Try the following:

  • Open Terminal.
  • Enter the following:

    wine reg add "HKCU\Software\Wine\Direct3D" /v OffscreenRenderingMode /d backbuffer

 

 

The registry value 'OffscreenRenderingMode' already exists. Do you want to overwrite it? (Yes|No)

 

I overwrote it but still not working properly :/


  • 0

#86 GargamelSE

GargamelSE

    I am New.

  • Members
  • 4 posts

Posted 25 June 2016 - 01:25 AM

After installing outside PoL (as in the guide).

the game installs, but when i launch the launcher, it starts to download some files, but crashes mid download

 

 

 System information:

    Wine build: wine-1.9.12
    Platform: i386
    Version: Windows XP
    Host system: Linux
    Host version: 4.4.0-21-generic
 

 

 

 

CQ8absL.png


Edited by GargamelSE, 25 June 2016 - 01:26 AM.

  • 0

#87 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 25 June 2016 - 02:43 AM

After installing outside PoL (as in the guide).
the game installs, but when i launch the launcher, it starts to download some files, but crashes mid download
 
 
 System information:
    Wine build: wine-1.9.12
    Platform: i386
    Version: Windows XP
    Host system: Linux
    Host version: 4.4.0-21-generic

[…]


Which Linux distribution are you using?
  • 0

#88 GargamelSE

GargamelSE

    I am New.

  • Members
  • 4 posts

Posted 25 June 2016 - 07:30 AM

Which Linux distribution are you using?

 

Latest Linux mint(cinnamon).    Linux Gargamel 4.4.0-21-generic #37~14.04.1-Ubuntu SMP Wed Apr 20 16:33:38 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux


  • 0

#89 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 25 June 2016 - 11:08 PM

Latest Linux mint(cinnamon).    Linux Gargamel 4.4.0-21-generic #37~14.04.1-Ubuntu SMP Wed Apr 20 16:33:38 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux


I've just installed the IRO client on Linux Mint 17.3 (64-bit) using my guide and didn't encounter any problems.  :unsure:

n5gWIuO.png
  • 0

#90 Inukaze

Inukaze

    I made it Off Topic

  • Members
  • 32 posts

Posted 29 June 2016 - 03:58 PM

Hi there i am using PlayOnLinux + Wine. but something strange, i see some deformed fonts , or not Smoothing applied to Fonts with AA subpixles.

 

Can you detail the Text on the follow screenshots :

 

Steam_RO001.png
Steam_RO002.png
Steam_RO003.png
Steam_RO_Text_001.png
Steam_RO_Text_002.png
Steam_RO_Text_003.png
Steam_RO_Text_004.png
 
Someone know a method to fix the fonts inside Ragnarok. Because in the Steam For WIndows. i see the Smoothing are applied, but not inside ragnarok.
 
 
 
 

  • 0

#91 Inukaze

Inukaze

    I made it Off Topic

  • Members
  • 32 posts

Posted 29 June 2016 - 04:04 PM

Which Linux distribution are you using?

 

I have Ragnarok using PlayOnLinux + Wine 1.8 Steam Cross Over Hack , Inside Debian 8.5 Jessie Stable & Manjaro OpenRC Xfce. and works fine

 

The things you need to run The Game

 

1 - Compatible Drivers for your VideoCard

2 - OpenGL Enabled

3 - Direct RederIng (DRI)

4 - Wine Compatible Version

5 - A Client Of Game ( i use Steam Client of Ragnarok )

 

I ever runs Ragnarok Online from 2004 under GNU/Linux, included Privated Servers. for Testing :D

 

If you talk spanish, you can read my Guide -> https://inukaze.word...al/instalacion/


  • 0

#92 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 30 June 2016 - 01:18 AM

Hi there i am using PlayOnLinux + Wine. but something strange, i see some deformed fonts , or not Smoothing applied to Fonts with AA subpixles.
 
Can you detail the Text on the follow screenshots :
 
[…]

Someone know a method to fix the fonts inside Ragnarok. Because in the Steam For WIndows. i see the Smoothing are applied, but not inside ragnarok.


Try the following in order:
  • Install the TrueType Core Fonts for the Web:

    apt-get install ttf-mscorefonts-installer
  • Enable font anti-aliasing:

    winetricks settings fontsmooth=rgb
  • Use font substitutions. (If I recall correctly, the IRO client uses the fonts Arial and MS Sans Serif.)

Edited by Axylus, 30 June 2016 - 01:29 AM.

  • 0

#93 MasterOfBytes80

MasterOfBytes80

    I made it Off Topic

  • Members
  • 69 posts
  • LocationGermany
  • Playing:Ragnarok Online
  • Server:Renewal Chaos

Posted 07 July 2016 - 03:48 AM

The registry value 'OffscreenRenderingMode' already exists. Do you want to overwrite it? (Yes|No)

 

I overwrote it but still not working properly :/

 

Didn't worked for me neither.

 

For my work-PC the following did help:

 

Starting winecfg and Enabled "Enable _CSMT for better graphic performance" in "Staging".


  • 0

#94 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 07 July 2016 - 10:08 AM

Didn't worked for me neither.

For my work-PC the following did help:

Starting winecfg and Enabled "Enable _CSMT for better graphic performance" in "Staging".


Wha — CSMT isn't enabled by default?! It's been enabled by default in CrossOver for a long time.

You may be able to determine why the client is freezing by running Wine from a terminal:
  • Open a terminal.
  • Enter the following:

    cd "$(winepath 'C:\Gravity\Ragnarok Online')" && wine Ragexe.exe 1rag1
  • Trigger the freeze.
  • Examine the messages printed to the console for clues.
Please be aware that the amount of help I can offer is limited because I don't use Linux as my primary OS.

Edited by Axylus, 07 July 2016 - 11:08 AM.

  • 0

#95 MasterOfBytes80

MasterOfBytes80

    I made it Off Topic

  • Members
  • 69 posts
  • LocationGermany
  • Playing:Ragnarok Online
  • Server:Renewal Chaos

Posted 07 July 2016 - 09:51 PM

So, i made some more testing on my home PC.

Maybe you want to add the results to your opening post.

(Logs aren't helpful when starting per console)

 

As said already i have to enable  "_CSMT for better graphic performance".

BUT: This option is only available when installing winehq-staging and not winehq-devel.

  • 0

#96 Inukaze

Inukaze

    I made it Off Topic

  • Members
  • 32 posts

Posted 15 July 2016 - 08:43 AM

You shouldn't use PoL because the installation script for RO hasn't been updated since June 2009.

 

Axylus if you wanna , the next week i can make an Script for Install Ragnarok

 

1 - Using Steam Client

2 - Using Pure Client ( without Steam )

 

Before i make some scripts for PlayOnLinux. for example "SuperCrateBox" , and still is working :D


  • 0

#97 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 15 July 2016 - 09:54 AM

Axylus if you wanna , the next week i can make an Script for Install Ragnarok
 
1 - Using Steam Client
2 - Using Pure Client ( without Steam )
 
Before i make some scripts for PlayOnLinux. for example "SuperCrateBox" , and still is working :D


I'd be happy to test the script and provide feedback. :)
  • 0

#98 Zeromir

Zeromir

    I made it Off Topic

  • Members
  • 19 posts

Posted 13 August 2016 - 03:14 PM

I fully installed everything according to your guide, and can get the client open. However, upon patching, it crashes mid-download. I'm not sure what I did wrong, but I think I can run the game fine, since I can run Phantasy Star Online Blue Burst using the Wine Windows Loader.


  • 0

#99 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 14 August 2016 - 03:47 AM

I fully installed everything according to your guide, and can get the client open. However, upon patching, it crashes mid-download. I'm not sure what I did wrong, but I think I can run the game fine, since I can run Phantasy Star Online Blue Burst using the Wine Windows Loader.


Just keep reopening the patcher until the process is successful.
  • 0

#100 Zeromir

Zeromir

    I made it Off Topic

  • Members
  • 19 posts

Posted 14 August 2016 - 09:08 AM

Just keep reopening the patcher until the process is successful.

Tried that, but it would only work for varying amounts of time. I ended up just getting the patched Steam files from my main computer, putting them on a flash drive, and playing it from there. Of course, running the game is using the instructions you have, just minus installing the game. Works like a charm!


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users