How to play Ragnarök Online on macOS - Page 3 - Technical Support/Bug Reporting - WarpPortal Community Forums

Jump to content


Photo
* * * * * 5 votes

How to play Ragnarök Online on macOS


  • Please log in to reply
544 replies to this topic

#51 Matche

Matche

    I am New.

  • Members
  • 5 posts

Posted 04 December 2010 - 06:25 AM

You missed step 5. Try again! :)

The â??run commandâ?? window should resemble this picture:

Posted Image

http://wikisend.com/download/610140/trylog.cxlog
i hope that i have done it right this time, it was to autostart RO, i guess.. :P
  • 0

#52 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 04 December 2010 - 06:38 AM

http://wikisend.com/download/610140/trylog.cxlog
i hope that i have done it right this time, it was to autostart RO, i guess.. :P


Which version of CrossOver Games are you using?

How old is your Mac?

Did you manually install any DLL files?
  • 0

#53 Matche

Matche

    I am New.

  • Members
  • 5 posts

Posted 04 December 2010 - 06:43 AM

Which version of CrossOver Games are you using?

How old is your Mac?

Did you manually install any DLL files?


as in my first post said i am using 9.2 because i couldnt get an older version
today, i put those 2 dll files on.. uh.. you know, the 2 you put on when you have 7.2 but i think i am going to remove them
my mac is about 3 or 4 years old (it's a macbook)
  • 0

#54 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 04 December 2010 - 07:27 AM

as in my first post said i am using 9.2 because i couldnt get an older version


Version 9.2 is fine.

today, i put those 2 dll files on.. uh.. you know, the 2 you put on when you have 7.2 but i think i am going to remove them


Using the wrong versions of mfc42.dll and msvcp60.dll will cause problems. Where did you download them from?

my mac is about 3 or 4 years old (it's a macbook)


I had many problems playing on my old MacBook, which all disappeared when I upgraded to a MacBook Pro.

I don't have any more solutions to suggest. You can ask CodeWeavers for help if you have a support subscription. Show them the same picture and log you posted in this thread.

Edited by richard, 26 March 2012 - 01:59 AM.

  • 0

#55 Matche

Matche

    I am New.

  • Members
  • 5 posts

Posted 04 December 2010 - 07:42 AM

Version 9.2 is fine.



Using the wrong versions of mfc42.dll and msvcp60.dll will cause problems. Where did you download them from?



I had many problems playing on my old MacBook, which all disappeared when I upgraded to a MacBook Pro.

I don't have any more solutions to suggest. You can ask CodeWeavers for help if you have a support subscription. Show them the same picture and log you posted in this thread.



i downloaded my DLL files from here http://www.dll-files.com/ but i had the ragnarok problem before downloading them so.. still thanks for your help..
  • 0

#56 Ixoyz

Ixoyz

    I am New.

  • Members
  • 1 posts

Posted 18 December 2010 - 02:52 PM

Hey, folks. Old-time player here, made a new account so I can play over the holidays. I've gotten Ragnarok to play on my Mac fine thus far, but I do have a question: how can you assign shortcuts and such? My F12 button corresponds to increasing the volume. Thanks in advance.
  • 0

#57 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 19 December 2010 - 04:03 AM

Hey, folks. Old-time player here, made a new account so I can play over the holidays. I've gotten Ragnarok to play on my Mac fine thus far, but I do have a question: how can you assign shortcuts and such? My F12 button corresponds to increasing the volume. Thanks in advance.


Follow the instructions in the Configuring your keyboard section of the guide. :)

Edited by richard, 26 March 2012 - 01:55 AM.

  • 0

#58 deoko

deoko

    I am New.

  • Members
  • 2 posts

Posted 06 February 2011 - 11:09 AM

Hello, im new here : )
i know it's an oooold post, but i have some troubles installing ragnarok online :<
>__< please help me a lil

the error im getting is:

Posted Image
link
My link

i am not sure if this has to do something with codeweavers server or something like that >.< but i've waited agees to play this.
  • 0

#59 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 06 February 2011 - 02:11 PM

Hello, im new here : )
i know it's an oooold post, but i have some troubles installing ragnarok online :<
>__< please help me a lil

the error im getting is:

Posted Image
link
My link

i am not sure if this has to do something with codeweavers server or something like that >.< but i've waited agees to play this.

Your picture shows that CrossOver Games failed in its attempt to download the RO client.

I recommend that you download the client separately if you haven't already, then follow only the instructions in my guide. I'm planning to update the official C4/CrossTie profile within the next few days to prevent this problem from occurring.

Edited by richard, 26 March 2012 - 01:45 AM.

  • 0

#60 deoko

deoko

    I am New.

  • Members
  • 2 posts

Posted 07 February 2011 - 06:36 AM

Oh o.o! then ill do that : )
thank you very much
  • 0

#61 ifunjc

ifunjc

    I am New.

  • Members
  • 2 posts

Posted 29 March 2011 - 12:41 PM

Hi there, i just downloaded the Crossover Games trial yesterday wishing to test out if RO works before purchasing it. However after trying countless things that other people have been suggested to do all i manage to come up with at best is a frozen Teen ESRB warning screen and the login music playing. Here is what i have done.

1. I downloaded the client from the iRO website. I ran it and the above happened. I change the resolutions and still did not work. Some even came up with just a black screen with no sound. I re-downloaded the cilent with Bittorrent to ensure that the file was whole. I even used another installation file from irowiki. With the file from the iRO website itself upon installation the patcher pops up and then a i get an error message saying something is wrong with the wine and to check the codeweavers compatibility page, after that that patch says fail to patch. i close it and it says installation is done. I reopen RO and now it begins to patch. Then all i get when i run the game is the frozen Teen ESRB warning Screen.

2. I have tried manually installing the .dll files and the backbuffer registry to no effect as well. i have since deleted all the bottles when trying over again.

3. I have the C++ and redist installed when i install RO.

4. I ensured that im running the Codeweaver 10.1 as i just downloaded it yesterday from the website 03/28.

5. I am using 27" iMAC 2.66Ghz intel core i5

I hope you can help me out ive been at it a few hours already. =(

Thanks in advance.
  • 0

#62 ifunjc

ifunjc

    I am New.

  • Members
  • 2 posts

Posted 29 March 2011 - 06:09 PM

Okay after a few more hours of tinkering it finally works! But now i cant play it in full screen mode. i also tried the method you suggested in the link in the first post. However it says it doesnt work with the present codeweaver? so theres no way to play it in fullscreen till a hotfix?
  • 0

#63 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 30 March 2011 - 06:49 AM

Full-screen mode technically works in CrossOver Games 10, but only at certain resolutions.

To configure the client to run in full-screen mode:

  • Disable virtual desktop mode if it's enabled.
  • Open the client's configurator.
  • Tick (check) "full-screen mode", then press "OK".

On my computer, the client only ran in full-screen mode without glitches at certain resolutions. You'll probably need to experiment to find a resolution that doesn't cause glitches on your computer. Press command-option-R to forcefully exit full-screen mode if the client is unresponsive.

Edited by richard, 12 February 2012 - 03:36 AM.

  • 0

#64 Shinjin6

Shinjin6

    Amateur Blogger

  • Members
  • 127 posts

Posted 08 April 2011 - 11:51 AM

Hi guys, I'm trying to get this to work, but with no luck.

Mine actually installed fine, it's all patched up and will even let me log in, but after I choose which server to join, it invariably says "Failed to Connect to Server". I've been fooling around with Port Forwarding since but no real luck, any help?
  • 0

#65 Shinjin6

Shinjin6

    Amateur Blogger

  • Members
  • 127 posts

Posted 08 April 2011 - 12:10 PM

I got it, no worries. Some very good information elsewhere on this site, nicely done.
  • 0

#66 Shinjin6

Shinjin6

    Amateur Blogger

  • Members
  • 127 posts

Posted 08 April 2011 - 12:56 PM

-_-, my bad, problems again. I actually got it working, was playing and everything, when I accidentally Command + F4'ed triggering the game shutdown. When I try to log in again, it now says Failed to Connect to Server before I even choose which server I want to play on, which is a step back from before. I'll look around again but if anyone sees this, help would be appreciated.
  • 0

#67 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 08 April 2011 - 01:55 PM

-_-, my bad, problems again. I actually got it working, was playing and everything, when I accidentally Command + F4'ed triggering the game shutdown. When I try to log in again, it now says Failed to Connect to Server before I even choose which server I want to play on, which is a step back from before. I'll look around again but if anyone sees this, help would be appreciated.


Which shortcut are you opening (from the "programs" menu)?

Edited by richard, 12 February 2012 - 03:30 AM.

  • 0

#68 Euphonix

Euphonix

    I am New.

  • Members
  • 2 posts

Posted 11 April 2011 - 10:25 AM

Hi guys, I'm trying to get this to work, but with no luck.

Mine actually installed fine, it's all patched up and will even let me log in, but after I choose which server to join, it invariably says "Failed to Connect to Server". I've been fooling around with Port Forwarding since but no real luck, any help?



Hello everyone. I used to play RO a long time ago and now im getting back into the game. I am having the exact same problem that Shinjin6 is having. Can anyone link me to the fix or suggest what i can do to get it working. I'm trying to load the Valkarie application. When I go to log in it says failed to connect to server. Any help would be appreciated!
  • 0

#69 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 11 April 2011 - 10:30 AM

Hello everyone. I used to play RO a long time ago and now im getting back into the game. I am having the exact same problem that Shinjin6 is having. Can anyone link me to the fix or suggest what i can do to get it working. I'm trying to load the Valkarie application. When I go to log in it says failed to connect to server. Any help would be appreciated!


You must now open the "Ragnarok" shortcut to play, regardless of which server you wish to play on.

Edited by richard, 12 February 2012 - 03:28 AM.

  • 0

#70 Euphonix

Euphonix

    I am New.

  • Members
  • 2 posts

Posted 11 April 2011 - 10:35 AM

You must now open the 'Ragnarök' shortcut to play, regardless of which server you play on.

So then, if i want to play on the free site, all i do is load the regular ragnarok application and choose valk server? Also, if i want to play on a P2P server, how do i do that?

I just tried the Ragnarok app the Ragnarok renewal app and the Valkarie app and they all give me the failed to connect to server window after trying to log in. Lame. =/

Edited by Euphonix, 11 April 2011 - 10:45 AM.

  • 0

#71 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 11 April 2011 - 10:45 AM

So then, if i want to play on the free site, all i do is load the regular ragnarok application and choose valk server?


Yes.

Also, if i want to play on a P2P server, how do i do that?


IRO's payment model was changed last Wednesday. A subscription is no longer required to play on Ymir or Yggdrasil, and all of the servers are now accessed using the same client.

See the relevant post on Gravity's web log for more information.
  • 0

#72 xShiek

xShiek

    I am New.

  • Members
  • 1 posts

Posted 16 June 2011 - 12:33 AM

Hey richard,

I hope u r still following this thread and that u can help me to run RO (fRO = the official french server) on my MacBookPro (early 2011) with CrossOver Games v9.2.

I have been trying the installation for several times now but it isnt working so far...

1. I downloaded the game from the official website: http://www.ragnaroke.../inscrire.php#2
(the full client - not bittorent)

2. And I started CrossOver Games

3. Created a new bottle and but the two dll files in the system32 folder (I got the files from my old computer with XP)

4. Install Software -> Unknown Software -> then I selected the client and started installation

5. Well, first the Ragnarok Installer poped up and I followed the steps (like I would install the game on windows), no problems during this installation and the Ragnarok installer told me that he successfully installed RO and I clicked on finish

6. But now the CrossOver Games installer is still loading (for almost two hours now) but not even moving (the progress bar stands still at the same point as it was when the Ragnarok installer was done)

Posted Image



Thank u so much for ur help!


CrossOver Games v10.1
I also tried to install Ragnarok with the newest version and downloading the CrossTie Profile (from ur guide) and I had the same problems.
But in this case I canceled the CrossOver Games installation and was able to start the ragnarok.exe and the patcher started to download the patches but with one of the last patches (in May) I got an error "Failed to get...".

I tried to test it with v9.2 and the CrossTie Profile but if I try to open the link from ur guide (com-codeweavers-crossover-crosstie:install?crosstie=http://www.codeweavers.com/bin/c4p/86) safari tells me that it cant open it.


UPDATE:
I downloaded the right Tie files for CrossOver Games 9.2 and CrossOver installed first some stuff like Visual C++, etc. and afterwards RO. Successfull RO installation and then the same problem with the CrossOver process bar. Its not moving and I canceled the installation again. Can't start the patcher.

Edited by xShiek, 16 June 2011 - 04:03 AM.

  • 0

#73 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 21 June 2011 - 01:39 PM

For the benefit of others, the ultimate problem that was preventing xShiek from playing FRO under CrossOver Games was that his Mac has only an integrated Intel GPU. According to CodeWeavers, Intel's GPU drivers are buggy and therefore often cause problems with CrossOver Games. In the case of the RO client, the most serious and frequent problem is the client freezing when run in a graphics resolution greater than 800 × 600.

Edited by richard, 25 March 2012 - 03:31 PM.

  • 0

#74 shinobi26

shinobi26

    I made it Off Topic

  • Members
  • 18 posts

Posted 10 July 2011 - 05:53 AM

I don't see there's another page before :)

Hi richard, :D

I found an error to play Ragnarok on my mac, here is my error :

Posted Image

I search on google to solve it and fortunately i found richard's post in page 1 :

I didn't say you skipped it; I said you might have put the files in the wrong location. Anyone is capable of making a simple mistake like that. :rofl:

The reason I think you've made a mistake is because no one else has this problem. However, if you're sure you've followed the instructions correctly, you can run the updater with logging enabled to reveal the cause of the problem:

  • Choose �??programs�??, �??run command�?? from the main menu.
  • Choose the bottle containing your IRO installation in the new window which is opened.
  • Press �??browse�??, then navigate to your client folder.
  • Choose the file corresponding to the type of server you want to play on:
    • Premium (Ymir): Ragnarok.exe
    • Free (Valkyrie): RagnarokFree.exe
    • Testing (Sakray): sakray.exe
  • Expand the �??debug options�?? section if it's not already expanded.
  • Tick (check) �??create log file�??.
  • Press �??run�??.
  • Save the log file anywhere.
  • Wait for the updater to open and close.
  • Upload the log file to a file sharing service such as Wikisend.
  • Reply to this post with the address of the uploaded log file.


i've follow the step and upload my log file, here is the link : http://wikisend.com/...72/newlog.cxlog

Please Help me :lol:
  • 0

#75 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 10 July 2011 - 07:49 AM

I don't see there's another page before :wacko:

Hi richard, :D

I found an error to play Ragnarok on my mac, here is my error :

Posted Image

I search on google to solve it and fortunately i found richard's post in page 1 :



i've follow the step and upload my log file, here is the link : http://wikisend.com/...72/newlog.cxlog

Please Help me :(


The log reveals that a process named FunChat.exe crashed, but I'm not sure why. Do you know what FunChat.exe is?

Edited by richard, 25 March 2012 - 03:31 PM.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users