Cannot change screen size - Technical Support/Bug Reporting - WarpPortal Community Forums

Jump to content


Photo
- - - - -

Cannot change screen size


  • Please log in to reply
9 replies to this topic

#1 nmdr0913

nmdr0913

    I am New.

  • Members
  • 3 posts

Posted 18 February 2016 - 12:34 AM

Hi everyone I played ragnarok when I was a kid and wanted to relive the glory. I have a 3200 x 1800 screen, Directx 12, and Windows 10. I finally got it to run under compatibility mode for windows 7. However, the screen size is small and won't let me click (Plus I can barely read anything). I tried going under settings and changing it and although it's saving my changes, the window is the same size. I've ran it under admin, matched the settings of Ragnarok and Ragnarok Classic, enabled full screen, uninstalled then reinstalled, and even edited the optioninfo.lua_1 file. It will either not work at all, or stay the same size. Help a young adult escape the adult world and relive her childhood please   :sob:


Edited by nmdr0913, 18 February 2016 - 12:35 AM.

  • 0

#2 VModCinnamon

VModCinnamon

    Tranquility

  • Senior Warpportal VM
  • 13678 posts
  • Playing:Ragnarok Online

Posted 18 February 2016 - 12:40 AM

How old is your game setup file?

Close the active game clients and make sure to run Setup.exe and Setup_Classic.exe as admin when making changes.


  • 0

#3 nmdr0913

nmdr0913

    I am New.

  • Members
  • 3 posts

Posted 18 February 2016 - 01:32 AM

I just downloaded the most recent one off the site. I tried running as admin and not running it as admin, but the screen is the same size. I know it's accepting it, though because every time I close then run settings, it would show the new settings I put. I'm not sure if it helps, but every time I first open it, it goes full screen for the patch and so is my mouse is huge. When I click play, though, it exits full screen and the size of everything reverts back to normal. I also tried taking a screen shot of the full screen but oddly my computer copies the shot as the same size as the game window.


  • 0

#4 VModCinnamon

VModCinnamon

    Tranquility

  • Senior Warpportal VM
  • 13678 posts
  • Playing:Ragnarok Online

Posted 18 February 2016 - 02:34 AM

Can we see that screenshot please?


  • 0

#5 nmdr0913

nmdr0913

    I am New.

  • Members
  • 3 posts

Posted 24 February 2016 - 03:30 PM

I finally got it to work through steam, however, the font size won't change. Also, maybe because the window of text is so small, it won't let me click on the screen. It works if I rapidly click on it, but it's very frustrating and probably not good for my mouse. If I get to the actual game, the mouse works fine, but once any other window/more accuracy is needed for the clicks is involved, it won't register.

 

screenshot of the size of the window. Will not change with the change in screen size.

http://tinypic.com/r/xmjw2q/9


  • 0

#6 NoDice

NoDice

    Amateur Blogger

  • Members
  • 430 posts
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 24 February 2016 - 04:03 PM

If the game got installed into the Program Files folder, please move it outside to C:

Also, which OptionInfo.lua file did you edit? The one in the savedata folder is the one that lets you manually adjust your screensize. At a higher resolution, the text size will remain the same. There is no way to scale it to be on par with the resolution so if the text seems very small to you, scale down to a lower one. Sometimes the game window doesn't let you click, just Alt+Tab back and it should work.


  • 0

#7 VModCinnamon

VModCinnamon

    Tranquility

  • Senior Warpportal VM
  • 13678 posts
  • Playing:Ragnarok Online

Posted 24 February 2016 - 04:29 PM

Not sure on this but it could be Windows or graphic card settings causing the issue. Are you using the default resolution on your system?
Also if possible check the font scaling under System > Settings.

Hopefully the folks can fetch in more ideas.


  • 0

#8 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 24 February 2016 - 04:56 PM

Are you using a display with a high pixel density? If so, then try the following:
  • Open File Explorer.
  • Navigate to the client installation folder.
  • Select the file Ragnarok.exe.
  • Press alt-enter.
  • Open the Compatibility tab.
  • Enable the option Disable display scaling on high-DPI settings.
  • Press OK.
  • Repeat steps 3–7 for the file Ragexe.exe.

Edited by Axylus, 24 February 2016 - 04:57 PM.

  • 0

#9 HeresNatan

HeresNatan

    Awarded #1 Troll

  • Banned
  • 988 posts
  • LocationEU banned?
  • Playing:Nothing
  • Server:Chaos NO MORE

Posted 13 October 2017 - 11:14 AM

didnt worked for me...

the dpi decreases quality of game

 


Edited by HeresNatan, 13 October 2017 - 11:32 AM.

  • 0

#10 HeresNatan

HeresNatan

    Awarded #1 Troll

  • Banned
  • 988 posts
  • LocationEU banned?
  • Playing:Nothing
  • Server:Chaos NO MORE

Posted 14 October 2017 - 06:53 AM

lnu7aNa.png


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users