Unable to enter Power Up site - Technical Support - WarpPortal Community Forums

Jump to content

- - - - -

Unable to enter Power Up site

  • Please log in to reply
2 replies to this topic

#1 8768160424095718987


    I made it Off Topic

  • Members
  • 36 posts
  • Playing:Nothing

Posted 11 May 2016 - 06:30 AM

I am not sure if there is another thread regarding this, i tried to search but i could not find specifics that can help me.


I could not go into the power up site, I always hit "Payment Error" message. 


I removed the ApBlocker, I connected my self to the internet directly and yet I still hit this error.


I am using Chrome and Firefox, even tried IE (yes I'm desperate) but results are all the same... Santa, please help me. 



If there are any suggestions, please throw it in. I really want to buy Premium and I don't have Zullies since I just started playing this game last 28 April 2016.


Thank you for not throlling. :)

  • 0

#2 Marizhkah


    I made it Off Topic

  • Members
  • 39 posts
  • Playing:Requiem

Posted 11 May 2016 - 02:19 PM

Check this thread.. might help :D



  • 0

#3 Zurn


    They pay me to post.

  • Members
  • 8468 posts
  • Playing:ROSE Online
  • Server:Arua

Posted 11 May 2016 - 02:48 PM

They were having problems with the sites earlier today as well, so be sure to check it again.

  • 0

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users