Culvert Quesr - Ragnarok 2 Guides - WarpPortal Community Forums

Jump to content


Culvert Quesr

  • Please log in to reply
3 replies to this topic

#1 bokuwaryu


    I am New.

  • New Members
  • 2 posts

Posted 16 April 2017 - 12:38 AM

Help please anyone. I am newbie to RO2. I cannot complete 2 quests:


The bug is too big: Get rid of golden thiefbug

Already killed the golden thiefbug several times (solo) and it didnt completed. I would try to join party but I already lv15. It said optimum level 8-14. Tried reset the dungeon but it didnt work


Training Exercise 2: Get Maden's Ring

No idea which mob should i kill. Already killed every bugs and toads and maus. No ring dropped.


I already tried reset the dungeon, abandon and re take the quest. Also didnt work. Please help. Thank you.

  • 0

#2 mscocca


    Amateur Blogger

  • RO2 Community Representative
  • 353 posts
  • LocationRome, Italy
  • Playing:Ragnarok Online 2
  • Server:Odin

Posted 16 April 2017 - 03:44 AM

Hello bokuwaryu,
Do what I am going to say:
- Press the key "N";
- Select "Find Dungeon";
- Scroll down and check the box of "Episode 1";
- Press "Find Dungeon";
You will be automatically teleported into the dungeon, you will be transformed into Eremes Guile!
To get "Maiden's Ring" you have to kill all the frogs in the dungeon.
If you still have problems with the quest, please do not hesitate to reply here.
  • 0

#3 bokuwaryu


    I am New.

  • New Members
  • 2 posts

Posted 16 April 2017 - 03:24 PM

Thank you mscocca. I tried and it worked. But then the golden bug quest re-appeared. I abandoned it for now.


I guess the Maya & Wolves quests are similar too. I tried the Maya one and I control some kind of old western cowboy character. Will do them later, i think.

  • 1

#4 foobarph


    I am New.

  • New Members
  • 1 posts

Posted 28 June 2020 - 06:46 PM

Hi mscocca.


Tried ur tip and it worked.


The side story is hard and I guess the bug is still there as reported in other forums. Oh well..

  • 0

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users