Client Issues - Technical Support/Bug Reporting - WarpPortal Community Forums

Jump to content


Photo
- - - - -

Client Issues


  • Please log in to reply
2 replies to this topic

#1 captainmaverick

captainmaverick

    I made it Off Topic

  • Members
  • 80 posts
  • Playing:Ragnarok Online
  • Server:Ymir

Posted 26 December 2010 - 09:27 PM

I have been trying to customize my homunculus, but somewhere down the lines of downloading the LUA reader and the custom AI maker, I have been getting this message: ./AI/USER_AI/AI.lua:2: could not load package `./AI/Const.lua' from path`;;C:\Program Files\Lua\5.1\lua\?.luac' I downloaded the stock AI folder and put it back in my RO folder, but that didn't fix the problem. I have also uninstalled the LUA reader program and it still gave me this message. Then I tried reinstalling the program and that didn't fix the issue. So, I started the IRO installer back up and hit repair so it would reinstall all of the files, but when I tried to start RO up, it gave me a new message before the patcher even started up. This message says: D:\SS\Local.lua:37: could not load package `./PatchClient/LuaFiles/ServerInfoz/ServerInfo_USA' from path ';;C:\ProgramFiles\Lua\5.1\lua\?.luac' After it gives me this message the patcher appears, but its just a white box and I have to hit alt+f4 in order to exit out of it.

Also, I have a second problem. I'm not sure if it's because I haven't used a homunc in forever, but before I began all this crap, I was trying to lvl my homunculus and for some reason it wasn't getting any experience. If someone can also let me know if it's just my ignorance or if there is a problem with my homunculus I'd appreciate it too.

Edit: For some reason I can play using the Renewal client, but I can't use the Ragnarok client or Valkyrie client and it still gives me the AI/Const.lua message when I try to access my alchemist.

Edit 2: I deleted everything and reinstalled RO and it fixed the problem. I guess there is an issue with the LUA program for editing AI scripts.

Edited by captainmaverick, 26 December 2010 - 11:43 PM.

  • 0

#2 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 27 December 2010 - 11:23 PM

It looks like the cause of the problem was the LUA editor you installed forcing the working directory of the RO LUA interpreter to the directory that the LUA editor was installed to, instead of the RO directory.

You do not need a LUA editor/tester/whatever to write AI code. AzzyAI was written in a text editor (TextPad, configured to provide lua syntax highlighting - that involved writing a .syn file, which i can dig up and post if you're interested)

Edited by DrAzzy, 27 December 2010 - 11:23 PM.

  • 0

#3 Guest_Holden_*

Guest_Holden_*
  • Guests

Posted 28 December 2010 - 04:02 PM

Unfortunately, you need to uninstall the Lua editor that you have because it is interfering with the client.
Notepad is more than enough to edit the AI.
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users