Ragnarok closes when using Photoshop - Renewal Technical Support / Bug Reporting - WarpPortal Community Forums

Jump to content


Photo
- - - - -

Ragnarok closes when using Photoshop


  • Please log in to reply
9 replies to this topic

#1 Yukimon

Yukimon

    I am New.

  • Members
  • 4 posts

Posted 05 August 2020 - 11:12 AM

I'll start by saying that I bought the sub for Photoshop so it's not the pirated one.

 

Also, I'll add that I have no issues whatsoever with InDesign and THAT one's pirated.

 

It seems to be within the usage of shortcuts but everyone I'm trying to work while leaving my vending on Ragnarok, it either closes on its own or says I'm using a pixelbot. 

 

I get that they want to avoid bots (which isn't really working, I've been my share of bots in eden maps) but it is kind of a pain in the butt that you legit cannot do anything outside the game, otherwise it triggers a false bot detection and closes the game. 

 

I just want to do my work while selling stuff and get some zeny :( 


  • 0

#2 Drupische

Drupische

    Amateur Blogger

  • Members
  • 138 posts
  • Playing:Ragnarok Online
  • Server:Renewal

Posted 05 August 2020 - 11:53 PM

Also, I'll add that I have no issues whatsoever with InDesign and THAT one's pirated.

 

strongbad.jpg

 

 

You can read this thread for some information: https://forums.warpp...k/?hl=photoshop


  • 0

#3 Yukimon

Yukimon

    I am New.

  • Members
  • 4 posts

Posted 06 August 2020 - 09:10 AM

strongbad.jpg


You can read this thread for some information: https://forums.warpp...k/?hl=photoshop


I've already checked it, there's no actual solution there.

And...yeah... I've bought software before by recommendation and it turned out to be useless. So I pirate it first, test it for a while and then decide if I want it. I use Psp daily so the decision was easy, ID... maybe 2 times? both during leaving Ro open not once did it crash so I'm sure the problem falls only with Psp.
  • 0

#4 Drupische

Drupische

    Amateur Blogger

  • Members
  • 138 posts
  • Playing:Ragnarok Online
  • Server:Renewal

Posted 06 August 2020 - 08:36 PM

Well, here are some things you can try out:

  • Before anything else, make sure you've installed the latest version of RO and is fully updated.
  • If you're running any programs that have some sort of pop-up feature, disable it. It seems to trigger EAC's Pixel Bot detector for some reason.
  • Uninstall and reinstall EAC...
    • There's an EasyAntiCheat folder in your RO installation folder - run the setup app inside it and choose the Uninstall option. After uninstalling EAC, restart your PC and run the setup file again to reinstall it
  • Uninstall RO completely using something like Revo Uninstaller to remove any trace of RO on your computer, and do a fresh install with the latest version of RO from warpportal.com...
    • Make sure you uninstall EAC first - as detailed above - beforehand.
    • Sometimes, the RO uninstaller doesn't work properly and only removes the uninstaller itsef rather than the entire game, which is why you need something like Revo Uninstaller.
  • Use a completely different computer to run RO on. This is what I personally do. All sorts of problems - including much higher computer resource use than usual and false detections - stem from EAC. If you have some other computer lying around your home, or if can find someone throwing out their old crummy Core 2 Duo PC, take it and run RO on it, especially if you want to vend.

  • 1

#5 ninJedi

ninJedi

    Too Legit To Quit

  • Members
  • 1147 posts
  • LocationPH: I don't wanna disconnect, Mr.Smart
  • Playing:Ragnarok Online
  • Server:Thor

Posted 07 August 2020 - 12:24 PM

I use Photoshop and RO together pretty often too so I also have some observations of my own.

That pixelbot error seems to show up a lot when my windows are arranged like this:
vuQ90Yj.png
(Basically, if the app I'm actively using is directly above/in front of the RO client)

Something about it seems to make RO think I'm running a pixelbot.
The error shows up even when I'm using other programs aside from PS (like Terraria, SketchUp, or Firefox).

But if I add another app underneath like this, I don't seem to encounter the pixelbot false positive anymore no matter how many hours I spend on PS:
Hj9XMjA.png
(Also works if I just insert windows explorer in between instead of task manager)

This is basically how I've been alt-tabbing RO with other programs for a while. It's not exactly a fix.
I honestly don't even know why it's like that but it works for me I guess lol :heh:

Also, it seems EAC will crash your client if the system is too stressed, so I can't keep RO open whenever I'm working on large projects :/

Edited by ninJedi, 07 August 2020 - 12:30 PM.

  • 1

#6 Yukimon

Yukimon

    I am New.

  • Members
  • 4 posts

Posted 08 August 2020 - 10:43 AM

I use Photoshop and RO together pretty often too so I also have some observations of my own.

That pixelbot error seems to show up a lot when my windows are arranged like this:
vuQ90Yj.png
(Basically, if the app I'm actively using is directly above/in front of the RO client)

Something about it seems to make RO think I'm running a pixelbot.
The error shows up even when I'm using other programs aside from PS (like Terraria, SketchUp, or Firefox).

But if I add another app underneath like this, I don't seem to encounter the pixelbot false positive anymore no matter how many hours I spend on PS:
Hj9XMjA.png
(Also works if I just insert windows explorer in between instead of task manager)

This is basically how I've been alt-tabbing RO with other programs for a while. It's not exactly a fix.
I honestly don't even know why it's like that but it works for me I guess lol :heh:

Also, it seems EAC will crash your client if the system is too stressed, so I can't keep RO open whenever I'm working on large projects :/

Wow, I usually play on fullscreen but I'm going to try this. Tried most of Drupische's to no avail :( though I appreciate him trying to help. I'll give yours a try and hope for the best.


  • 0

#7 Drupische

Drupische

    Amateur Blogger

  • Members
  • 138 posts
  • Playing:Ragnarok Online
  • Server:Renewal

Posted 08 August 2020 - 01:54 PM

I use Photoshop and RO together pretty often too so I also have some observations of my own.

That pixelbot error seems to show up a lot when my windows are arranged like this:
vuQ90Yj.png
(Basically, if the app I'm actively using is directly above/in front of the RO client)

Something about it seems to make RO think I'm running a pixelbot.
The error shows up even when I'm using other programs aside from PS (like Terraria, SketchUp, or Firefox).

But if I add another app underneath like this, I don't seem to encounter the pixelbot false positive anymore no matter how many hours I spend on PS:
Hj9XMjA.png
(Also works if I just insert windows explorer in between instead of task manager)

This is basically how I've been alt-tabbing RO with other programs for a while. It's not exactly a fix.
I honestly don't even know why it's like that but it works for me I guess lol :heh:

Also, it seems EAC will crash your client if the system is too stressed, so I can't keep RO open whenever I'm working on large projects :/

 

That's fascinating. If you have more than one monitor, can you try playing the game, in windowed and full-screen, on one monitor and use Photoshop on the other? I'm wondering if this can work- or if you have a really wide monitor, can you try playing RO in windowed mode and use PS without them overlapping? I'd try, but I don't have PS or any other Adobe products (that are recent enough to matter).

 

Wow, I usually play on fullscreen but I'm going to try this. Tried most of Drupische's to no avail :( though I appreciate him trying to help. I'll give yours a try and hope for the best.

 

Yeah, sorry I couldn't help. I know the last one isn't the most realistic approach, but maybe you can try what I suggested to ninJedi, to see if it works.


  • 0

#8 Kashmiir

Kashmiir

    I made it Off Topic

  • Members
  • 36 posts
  • LocationBuenos Aires
  • Playing:Ragnarok Online
  • Server:Ymir

Posted 08 August 2020 - 04:23 PM

It seems to be within the usage of shortcuts but everyone I'm trying to work while leaving my vending on Ragnarok, it either closes on its own or says I'm using a pixelbot. 

 

 

The same thing happens to me when I connect my mouse, I do not use any macro but EAC still considers me a pixelbot. It started to happen to me since the last maintenance. 
 
I hope they can fix it.

  • 0

#9 Yukimon

Yukimon

    I am New.

  • Members
  • 4 posts

Posted 10 August 2020 - 12:58 PM

 

The same thing happens to me when I connect my mouse, I do not use any macro but EAC still considers me a pixelbot. It started to happen to me since the last maintenance. 
 
I hope they can fix it.

 

Well, that sucks =/ I mean, I get that they're trying to stop bots, but it's also making it very difficult for the rest of us as well.

 

That's fascinating. If you have more than one monitor, can you try playing the game, in windowed and full-screen, on one monitor and use Photoshop on the other? I'm wondering if this can work- or if you have a really wide monitor, can you try playing RO in windowed mode and use PS without them overlapping? I'd try, but I don't have PS or any other Adobe products (that are recent enough to matter).

 

 

Yeah, sorry I couldn't help. I know the last one isn't the most realistic approach, but maybe you can try what I suggested to ninJedi, to see if it works.

 

I just noticed that it EAC starts up when I use the F's to work, I use them a lot for my Actions on Photoshop and seem to cause conflict with the client... It's really making things so difficult.

 

Update: Or so I thought.... I just had photoshop open while doing nothing and it still closed rag.exe, welp. That's that.


Edited by Yukimon, 10 August 2020 - 03:12 PM.

  • 0

#10 Drupische

Drupische

    Amateur Blogger

  • Members
  • 138 posts
  • Playing:Ragnarok Online
  • Server:Renewal

Posted 12 August 2020 - 06:03 PM

I just noticed that it EAC starts up when I use the F's to work, I use them a lot for my Actions on Photoshop and seem to cause conflict with the client... It's really making things so difficult.

 

Update: Or so I thought.... I just had photoshop open while doing nothing and it still closed rag.exe, welp. That's that.

 

Sorry to hear about that. It seems that your only choices at this point are to: not use Photoshop or whatever Adobe product while playing RO, uninstall the Adobe software altogether, or use VIP items to vend offline. The first two are definitely not feasible, and the third can cost you several IRL bucks, or millions of zeny if bought from another player.


Edited by Drupische, 12 August 2020 - 06:05 PM.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users