Camera not saving setting after client restart - Renewal Testing - WarpPortal Community Forums

Jump to content


Photo

Camera not saving setting after client restart


  • Please log in to reply
19 replies to this topic

#1 FoxyWoxy

FoxyWoxy

    Amateur Blogger

  • Members
  • 362 posts
  • Playing:Ragnarok Online

Posted 09 September 2010 - 12:27 AM

I rotate the camera downwards, restart client and the camera is back to being bird's eye. Wasn't like that pre renewal so bug?
  • 0

#2 ZeroTigress

ZeroTigress

    My Offline Life is Nonexistent.

  • RO1 Member
  • 15096 posts
  • Playing:Ragnarok Online
  • Server:Sakray->Iris->Ymir->Chaos

Posted 09 September 2010 - 12:43 AM

I've never ran into that problem. The camera always stays the way I last set it, pre- and post-Renewal. :p_devil:
  • 0

#3 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 09 September 2010 - 07:12 AM

If you're running non-renewal clients, that could likely mess things up.

And, why would you ever adjust the camera angle down? It looks like crap and makes it hard to walk.
  • 0

#4 espeon

espeon

    Awarded #1 Troll

  • Members
  • 636 posts
  • LocationUnited States
  • Playing:Ragnarok Online
  • Server:Ymir

Posted 09 September 2010 - 07:12 AM

All configuration changes revert when you close the client, even the window position.


If you're running non-renewal clients,

Nope.

And, why would you ever adjust the camera angle down? It looks like crap and makes it hard to walk.

It defaults to a higher angle for some reason. :p_devil:

Edited by espeon, 09 September 2010 - 07:37 AM.

  • 0

#5 entangle

entangle

    Amateur Blogger

  • Members
  • 108 posts
  • Playing:Nothing
  • Server:Loki

Posted 09 September 2010 - 07:27 AM

Yeah, it's really annoying. Another problem seems to be the new equipment window that is tied to the Status Window. It automatically opens when entering a new portal, very annoying.

Wish the client would save the settings when it closes.
  • 0

#6 espeon

espeon

    Awarded #1 Troll

  • Members
  • 636 posts
  • LocationUnited States
  • Playing:Ragnarok Online
  • Server:Ymir

Posted 09 September 2010 - 07:42 AM

Another problem seems to be the new equipment window that is tied to the Status Window.

That's a feature of the client overhaul. Both can still be minimized, but you actually have to click the minimize buttons (would've been nice if HQ had kept the Ctrl key combinations for minimizing windows :< ).
  • 0

#7 ZeroTigress

ZeroTigress

    My Offline Life is Nonexistent.

  • RO1 Member
  • 15096 posts
  • Playing:Ragnarok Online
  • Server:Sakray->Iris->Ymir->Chaos

Posted 09 September 2010 - 07:47 AM

Another problem seems to be the new equipment window that is tied to the Status Window.

A lot of games do that so players can see how their stats are affected by gears and weapons. Also eliminates having to open two separate windows in order to view them. Though I keep finding myself still in the habit of pressing alt+a to view my stats when now I have to press alt+q to view them.
  • 0

#8 Ultimate

Ultimate

    Ultimate Event Inventor

  • Members
  • 2506 posts
  • LocationValhalla Dwarf NPC
  • Playing:Ragnarok Online

Posted 09 September 2010 - 07:53 AM

Yeah, it's really annoying. Another problem seems to be the new equipment window that is tied to the Status Window. It automatically opens when entering a new portal, very annoying.

Wish the client would save the settings when it closes.


I believe the auto-popup is getting fixed. The GMs found it rather annoying while testing if I remember correctly. Also, alt+q/alt+e is tricky to get used to, easy to accidentally assign status points :S
  • 0

#9 entangle

entangle

    Amateur Blogger

  • Members
  • 108 posts
  • Playing:Nothing
  • Server:Loki

Posted 09 September 2010 - 08:38 AM

You miss understood me. I mean, every time I minimize it, it opens up again when I go through a portal, or resets the location I put it.
  • 0

#10 Ultimate

Ultimate

    Ultimate Event Inventor

  • Members
  • 2506 posts
  • LocationValhalla Dwarf NPC
  • Playing:Ragnarok Online

Posted 09 September 2010 - 08:43 AM

You miss understood me. I mean, every time I minimize it, it opens up again when I go through a portal, or resets the location I put it.


yeah they're working on it i think.
  • 0

#11 ZeroTigress

ZeroTigress

    My Offline Life is Nonexistent.

  • RO1 Member
  • 15096 posts
  • Playing:Ragnarok Online
  • Server:Sakray->Iris->Ymir->Chaos

Posted 09 September 2010 - 08:48 AM

Would love it if my settings were all server-side. Having to re-set everything is getting old real fast. :o

EDIT:

OS: Windows XP (SP 3)
Installation: c:/program files/gravity/ragnarok renewal
UAC: nonexistent
More details here (scroll all the way down)

Edited by ZeroTigress, 09 September 2010 - 01:25 PM.

  • 0

#12 espeon

espeon

    Awarded #1 Troll

  • Members
  • 636 posts
  • LocationUnited States
  • Playing:Ragnarok Online
  • Server:Ymir

Posted 09 September 2010 - 09:42 AM

Would love it if my settings were all server-side. Having to re-set everything is getting old real fast. :o

Settings are not being saved because the client reverts OptionInfo.lua to its default state on exit instead of saving any changes that were made. The client also seems to ignore the settings in this file, since manually editing the file has no effect. =\

G:\RagnarokOnlineRE\data>ls -a -1
.
..
ChatWndInfo_U.lua
OptionInfo.lua
UserKeys.lua


Useful crap
Spoiler

Edited by espeon, 09 September 2010 - 10:29 AM.

  • 0

#13 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 09 September 2010 - 09:44 AM

It sounds like a problem saving the client settings (which are stored in the registry). Players experiencing this problem (since it sounds like not everyone is) should post details on their OS version and how they have RO installed (ie, UAC-bypassing things, in case that is the source of the problem).
  • 0

#14 espeon

espeon

    Awarded #1 Troll

  • Members
  • 636 posts
  • LocationUnited States
  • Playing:Ragnarok Online
  • Server:Ymir

Posted 09 September 2010 - 10:42 AM

Settings for the renewal client are saved in LUA files in the /data/ directory.

OptionInfo.lua
ChatWndInfo_U.lua
  • 0

#15 Hrishi

Hrishi

    Too Legit To Quit

  • Members
  • 2192 posts
  • Playing:Nothing

Posted 09 September 2010 - 11:09 AM

When you edit the BGM/Effect volume and all that, it does not save when you restart the client. It goes back to the default levels for both.
  • 0

#16 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 09 September 2010 - 11:48 AM

I'm also experiencing this problem and I play the game under Wine, which gives all processes full access to the file system and registry.

The following settings are also not saved:

  • Window position
  • Log window configuration
  • Vertical camera angle
  • Skill window view state (whether it's in list or tree view)

Edited by richard, 26 March 2012 - 03:31 AM.

  • 0

#17 espeon

espeon

    Awarded #1 Troll

  • Members
  • 636 posts
  • LocationUnited States
  • Playing:Ragnarok Online
  • Server:Ymir

Posted 09 September 2010 - 11:56 AM

See here.
  • 0

#18 espeon

espeon

    Awarded #1 Troll

  • Members
  • 636 posts
  • LocationUnited States
  • Playing:Ragnarok Online
  • Server:Ymir

Posted 09 September 2010 - 07:00 PM

OptionInfo.lua

I just noticed something while playing around with thisâ?¦ The OptionInfoList variables are duplicated, and since this file gets reverted each time the client exits, deleting the duplicates does no good.
  • 0

#19 Soukosa

Soukosa

    I made it Off Topic

  • Members
  • 48 posts

Posted 09 September 2010 - 08:52 PM

Running the renewal client messes up the settings for the pre-renewal client too, so apparently it is writing stuff to the registry when it shouldn't be.
  • 0

#20 inuko23

inuko23

    Too Legit To Quit

  • Members
  • 1182 posts
  • Playing:Ragnarok Online
  • Server:Chaos, Odin (RO2)

Posted 09 September 2010 - 09:29 PM

It sounds like a problem saving the client settings (which are stored in the registry). Players experiencing this problem (since it sounds like not everyone is) should post details on their OS version and how they have RO installed (ie, UAC-bypassing things, in case that is the source of the problem).


OS:
Windows Vista Home Premium
Install directory: C:\WarpPortal\Ragnarok Renewal
UAC:
ran Ragnarok Renewal installer as administrator; I usually right click "run as administrator" when I'm opening the client as well

Edited by inuko23, 09 September 2010 - 09:30 PM.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users