AzzyAI 1.50 beta - 2/28 - Dev 17 posted, Eira fixes - Page 21 - Homunculus Headquarters - WarpPortal Community Forums

Jump to content


Photo
* * * * * 4 votes

AzzyAI 1.50 beta - 2/28 - Dev 17 posted, Eira fixes


  • This topic is locked This topic is locked
520 replies to this topic

#501 Stimulation

Stimulation

    I am New.

  • Members
  • 2 posts

Posted 20 May 2013 - 06:09 AM

Posted Image

Posted Image

Posted Image

I'd say I installed everything properly and since the homu is circling around me the AI is working. Theres only a problem with the atk/skill stuff i guess... though i don't know what that error log means.. ^^

Edited by Stimulation, 20 May 2013 - 07:08 AM.

  • 0

#502 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 20 May 2013 - 08:24 AM

Posted Image

Posted Image

Posted Image

I'd say I installed everything properly and since the homu is circling around me the AI is working. Theres only a problem with the atk/skill stuff i guess... though i don't know what that error log means.. ^^

Oh, there's the problem.

AzzyAI does not work on illegal private servers as is clearly stated in the documentation. eA assigns actor ID's differently, and my AI relies on how the official servers do it in order to make up for the lack of proper API calls to differentiate between players in a pvp zone and monsters.
  • 0

#503 Atrista

Atrista

    I made it Off Topic

  • Members
  • 45 posts
  • Locationbehind you!
  • Playing:Ragnarok Online
  • Server:Yggdrasil

Posted 20 May 2013 - 03:44 PM

uhm.. maybe, it's just me being stupid and not being able to configure it correctly but i noticed my bayeri doesnt auto-cast stein wand after teleporting, it's supposed to do that when UseSteinWandTele is set to true right? x_x i just almost got killed in a huge mob while trying to make this work
  • 0

#504 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 20 May 2013 - 08:06 PM

Hmm....

I don't have a bay to test on. Unless I was doing something strange, I think I got a test backwards.

Install RC8 if you haven't already, and replace AI_main with this version:

http://www.drazzy.co...nWand Patch.zip

I think that will fix it.
  • 0

#505 Atrista

Atrista

    I made it Off Topic

  • Members
  • 45 posts
  • Locationbehind you!
  • Playing:Ragnarok Online
  • Server:Yggdrasil

Posted 21 May 2013 - 09:53 AM

oh.. i`m not sure what rc8 is.. i might have it.. or i might not... sorry... i tried to search for this but i dont know where to find it... whatever it is.. but i exchanged the AI_main with the one you posted, when i got into the game and summoned my homun it gave me this error:
Posted Image
the error wouldnt go away and i had to close the window through task manager. this could be because i dont have the rc8 thing?
  • 0

#506 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 21 May 2013 - 09:58 AM

Yes. That patch needs to get installed over RC8. You're using an earlier version.

Download: http://drazzy.com/ai...0 Final RC8.zip
  • 0

#507 Atrista

Atrista

    I made it Off Topic

  • Members
  • 45 posts
  • Locationbehind you!
  • Playing:Ragnarok Online
  • Server:Yggdrasil

Posted 21 May 2013 - 10:34 AM

okay, i did that now it gave me this error:
Posted Image
this error pops up every 2 seconds or so after i press ok, i`m thinking it might be because the bay is trying to recast stein wand constantly and there might be a problem when he casts it, i`m thinking that because i saw him use the /... emote right before the error pops up, he casted stein wand then tried to cast it again just a second or so after?
  • 0

#508 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 21 May 2013 - 11:35 AM

It's a typo - config file and GUI call the option StienWandTelePause, while the AI is looking for SteinWandTelePause. Since that variable isn't defined, the AI crashes when it tries to calculate the time that it should next try to act by adding the current time to it. Because of that, it isn't able to record that it's used Steinwand, and tries to recast it repeatedly.

Add this line to H_Extra (this can be done through the config tool on the extras tab):
SteinWandTelePause	   = 3000
And now see if it works.

Edited by DrAzzy, 21 May 2013 - 11:39 AM.

  • 0

#509 Atrista

Atrista

    I made it Off Topic

  • Members
  • 45 posts
  • Locationbehind you!
  • Playing:Ragnarok Online
  • Server:Yggdrasil

Posted 21 May 2013 - 11:43 AM

cool, now with that it's working, he only tried to recast it when i teleport and didnt give any more errors. thanks azzy~
i`ll let you know if i find any more problems with the ai
  • 0

#510 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 21 May 2013 - 11:55 AM

Nice!

Let me know if any of yall have other issues with the AI. Official 1.50 release should happen this weekend, unless someone finds some scary problem.
  • 0

#511 Sapphic

Sapphic

    Too Legit To Quit

  • RO Fungineering
  • 2660 posts
  • Playing:Ragnarok Online

Posted 22 May 2013 - 03:47 AM

Hmm I'm getting these afking in od2:
05/21/13 23:53:04 M4 Attempt to move to location 327,313 which is 18 cells from owner, call disregarded
05/21/13 23:53:05 M4 Attempt to move to location 327,313 which is 18 cells from owner, call disregarded
05/21/13 23:53:05 M4 Attempt to move to location 327,313 which is 18 cells from owner, call disregarded
05/21/13 23:53:05 M4 Attempt to move to location 327,313 which is 18 cells from owner, call disregarded
05/21/13 23:53:05 M4 Attempt to move to location 327,313 which is 18 cells from owner, call disregarded
05/21/13 23:53:05 M4 Attempt to move to location 327,313 which is 17 cells from owner, call disregarded

I think my homu is freezing up or something - I haven't caught it in action, but it's been dying / getting really hurt for some reason in od2. It's an amistr/dieter with lava slide so...

I changed stationary move bound and aggro stationary dist both to 11 and it stopped. I think orc archers were making it go weird.

Edited by Sapphic, 22 May 2013 - 11:08 AM.

  • 0

#512 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 22 May 2013 - 03:08 PM

What did you have for MoveBound and StationaryAggroDist?

Edited by DrAzzy, 22 May 2013 - 04:02 PM.

  • 0

#513 Sapphic

Sapphic

    Too Legit To Quit

  • RO Fungineering
  • 2660 posts
  • Playing:Ragnarok Online

Posted 22 May 2013 - 03:10 PM

It was at 14 and 12 before.

It's still at 11/11 now. I caught an Orc Archer freezing it. It stopped when another archer spawned closer to it.

It's a long trace:
Spoiler

No errors, though.

The thing is, the archer wasn't that far at all
Posted Image
It was in that area.

Edited by Sapphic, 22 May 2013 - 03:13 PM.

  • 0

#514 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 22 May 2013 - 04:12 PM

Okay - just read those more carefully..., those errors were from your mercenary, not your homun! ( the M4 means Mercenary in state 4, which is MOVE_CMD state). Basically, I think that error means that you ordered your merc to walk off screen.

That's unrelated to homun settings or getting stuck.

Judging by that trace, the homun is getting stuck because it had an archer attacking it from outside movebounds, but that's the highest priority target, and it's attacking the homun (or owner), so it returns to it as target as soon as it drops it. Set the StationaryMoveBound back up to 14 or so and that should prevent it.

... and because of fastchange, it doesn't see that it dropped the target last cycle, and thus the mechanisms I have in place for preventing such hangs don't work.
Positions of enemy, owner, homun.
E









	H

	  O

Edited by DrAzzy, 22 May 2013 - 04:16 PM.

  • 0

#515 Sapphic

Sapphic

    Too Legit To Quit

  • RO Fungineering
  • 2660 posts
  • Playing:Ragnarok Online

Posted 22 May 2013 - 05:16 PM

Ooh okay I moved it back up to 14. I hope I can catch what was getting it stuck last night if it even happens anymore.

Also oh lol I did have a merc out for a bit, though I didn't command her to do anything manually.
  • 0

#516 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 22 May 2013 - 08:41 PM

Ooh okay I moved it back up to 14. I hope I can catch what was getting it stuck last night if it even happens anymore.

Also oh lol I did have a merc out for a bit, though I didn't command her to do anything manually.

I do too - I want to prevent the AI from ever getting stuck. Stuck AI = dead owner.

My guess is you were rotating the screen or something and accidentally did the merc move command.
  • 0

#517 Sapphic

Sapphic

    Too Legit To Quit

  • RO Fungineering
  • 2660 posts
  • Playing:Ragnarok Online

Posted 23 May 2013 - 11:33 AM

Well I leveled it for hours yesterday without issue. I dunno if it was the spot I was in or if changing mobile aggro dist from 12 to 11 did it, but it hasn't happened yet. Although there hasn't been much instances of Orc Archers being sneaky since the map is so crowded lol.

Edited by Sapphic, 23 May 2013 - 11:34 AM.

  • 0

#518 D111

D111

    Too Legit To Quit

  • Members
  • 4540 posts
  • LocationOrlando
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 23 May 2013 - 06:35 PM

Azzy you're the Best!!! :p_love:
  • 0

#519 aregas

aregas

    I made it Off Topic

  • Members
  • 11 posts
  • LocationCopperas Cove, Texas
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 26 May 2013 - 08:44 AM

Azzy; I have a question, I use your AI and I have for a long time, but I've never been able to get my Vanlimirth to use it's skills automatically. It's always had to be manual.
  • 0

#520 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 26 May 2013 - 12:23 PM

Please post contents of AAIStartH.txt in your RO folder, so we can see what version youre using. If that file is not present, my AI isn't actually being used. AzzyAI will use skills with default settings, and can detect homun S's that were formerly vanis.

Edited by DrAzzy, 26 May 2013 - 12:23 PM.

  • 0

#521 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 27 May 2013 - 06:12 PM

AzzyAI 1.50 has been released! Please see the announcement thread.

Support for 1.50 dev and RC versions is discontinued.
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users