[Testing]Client does not save settings - Confirmed bugs - WarpPortal Community Forums

Jump to content


Photo

[Testing]Client does not save settings


  • Please log in to reply
47 replies to this topic

#1 Idol

Idol

    I am New.

  • Members
  • 9 posts

Posted 27 May 2011 - 08:01 PM

Ever since we've been asked to change clients a little while back, I've been having this issue where my client does not retain any changes I make to it, once I close it. As an example, if I make changes to my chat windows, once I close and restart my client, those changes will have gone away. The same goes for sound settings, and other such modifications. Oddly enough, I do not have the same problem with my laptop. My desktop, which is the one that has this problem, runs windows XP service pack 2.
  • 0

#2 Chucklet

Chucklet

    Awarded #1 Troll

  • Members
  • 502 posts
  • LocationThe Netherlands [NL], stuck in traffic.
  • Playing:Ragnarok Online
  • Server:Ymir(?)

Posted 28 May 2011 - 04:46 AM

At least one thing you can check is how you CLOSE the ro client. Pressing alt-f4 or any other forced shutdown will mean setting are NOT saved.

It could be that it is an XP issue but most of the times the older the system you are using the less issues there are. If you run the ro client on your working laptop under 'compatibility mode'>winXp sp2 do you get the same problem?

Edit: scrap* nvm Oda beat me to that other point -_-

Edited by Chucklet, 28 May 2011 - 04:52 AM.

  • 0

#3 Oda

Oda

    Overseas

  • Community Managers
  • 10198 posts
  • Twitter:@Oda_CM
  • LocationAmatsu
  • Playing:Ragnarok Online

Posted 28 May 2011 - 04:50 AM

You might want to check your RO game folder and client to see if anything is marked as "read only"
  • 0

#4 Idol

Idol

    I am New.

  • Members
  • 9 posts

Posted 28 May 2011 - 09:31 AM

A few items were marked as read only, so I attempted to check off that option for the folder and it's contents. I started a client, made changes to it (chat window and sound options), closed the client the same way I always do (pressing exit, not alt+f4 or killing the process), started a new client and none of the changes have been saved. I then tried it the other way around, making all the files read only, in case that could somehow be the problem, and no success there either.
  • 0

#5 Oda

Oda

    Overseas

  • Community Managers
  • 10198 posts
  • Twitter:@Oda_CM
  • LocationAmatsu
  • Playing:Ragnarok Online

Posted 28 May 2011 - 10:00 AM

Do you have admin privileges in your Windows login? If you are admin, you might try right clicking the ragnarok.exe and select "Run as an administrator"
  • 0

#6 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 28 May 2011 - 10:08 AM

If you're on windows 7 or vista, and RO is installed to program files, you have no guarantee that the files you're changing the read-only status on are the real versions of the file, or a virtualized one. Since RO is supposed to only be run as admin (and it looks like they _finally_ sorted that out recently - i think it now tries to run itself as admin, though I have zero faith in it doing that reliably - UAC behavior is incredibly unpredictable), it would see the real one (assuming it was working correctly), while the user would see the virtualized one. There is no simple way to tell whether or not files are being virtualized by UAC.

I'd uninstall RO entirely, and reinstall it to a location outside of program files, and see if that fixes it.

Edited by DrAzzy, 28 May 2011 - 10:09 AM.

  • 0

#7 Idol

Idol

    I am New.

  • Members
  • 9 posts

Posted 28 May 2011 - 10:54 AM

As I've stated in my OP, my desktop runs XP SP2. Thanks for the input though, hopefully we find what the problem is soon!
  • 0

#8 Idol

Idol

    I am New.

  • Members
  • 9 posts

Posted 29 May 2011 - 07:49 PM

Any suggestions?
  • 0

#9 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 29 May 2011 - 07:56 PM

I've got nothing - no clue why this would not be working under XP.
  • 0

#10 Kimea

Kimea

    Amateur Blogger

  • Members
  • 136 posts
  • LocationWhere the sun shines
  • Playing:Ragnarok Online
  • Server:Renewal

Posted 28 December 2011 - 09:18 AM

Guys I've read all the posts and read what Oda posted about files being "read only". So I checked the RO Game Folder itself and guess what.... IT IS read only. I try that and see if it fixes it.
  • 0

#11 pikachiquita5

pikachiquita5

    Amateur Blogger

  • Members
  • 314 posts
  • Playing:Ragnarok Online
  • Server:Ymir

Posted 28 December 2011 - 08:03 PM

Is it fine then just to alter it so that it is no longer read-only under folder properties? I'm having the same issue where the settings are no longer saved; it was a recent thing, guess with the client alterations.

If not, I'll try installing it outside of the program folder and see if that helps. I can live with it, but it is annoying that I have to fix the settings every time.

EDIT: I tried to make the folder *NOT* be read-only, but it resets itself to such every time. I'm thinking I'll have to uninstall-reinstall the whole game....I'll try to put it somewhere other than the program files folder and see if that makes a difference.

Edited by pikachiquita5, 30 December 2011 - 02:18 AM.

  • 0

#12 Uruwashii

Uruwashii

    Amateur Blogger

  • Members
  • 167 posts
  • Playing:Ragnarok Online
  • Server:RE:Start

Posted 30 December 2011 - 06:08 AM

I'm actually in the same boat guys.... Ever since the last patch none of my settings save.

I have tried all of the above. Read Only, not in program files, run in admin/not admin, re-installing the entire game.
It only started happening since the last big patch update.

It does not save my sound, current AI custom status, /aura, etc. Very annoying.



quick fix

Hop into this folder

C:\Ragnarok Online\data

And look for the file name OptionInfo.lua

At the top you can change the settings that you want to log in with.
Hopefully this will suffice until an admin helps us out. Not sure what it could be.

Edited by Uruwashii, 30 December 2011 - 06:26 AM.

  • 0

#13 CommieChinchilla

CommieChinchilla

    I am New.

  • Members
  • 1 posts
  • Playing:Ragnarok Online

Posted 30 December 2011 - 11:38 AM

In that case which option handles the NPC chat box and it's option sets, so i can play with the position? thanks in advance @.@
  • 0

#14 solowolf90

solowolf90

    I made it Off Topic

  • Members
  • 13 posts

Posted 31 December 2011 - 08:33 PM

Hmmm, I have the same problem too. Sound not saving at all.
  • 0

#15 Ruefus

Ruefus

    I made it Off Topic

  • Members
  • 10 posts

Posted 01 January 2012 - 03:05 PM

quick fix

Hop into this folder

C:\Ragnarok Online\data

And look for the file name OptionInfo.lua

At the top you can change the settings that you want to log in with.
Hopefully this will suffice until an admin helps us out. Not sure what it could be.


As far as the sound settings not saving goes, this fix worked for me. In the Gravity>Ragnarok Online>Data>OptionInfo.lua file, in the first chunk of options I changed both CmdOnOffList["/bmg"] = 0 and CmdOnOffList["/sound"] = 0 from 0 to 1 and now I have sound as soon as I launch RO.
  • 0

#16 wonka

wonka

    Amateur Blogger

  • Members
  • 420 posts
  • LocationAltamierda, Tamaulipas, Mexico~
  • Playing:Ragnarok Online
  • Server:Loki>Ymir>Chaos~

Posted 13 January 2012 - 02:49 AM

i have the same issue i solved it lol i just copied an old ro folder from a backup dvd i had and updated it (took several minutes cus' client was when renewal just hitted) but it worked anyways GM's should do something to solve this~
  • 0

#17 Thexare

Thexare

    I made it Off Topic

  • Members
  • 35 posts
  • LocationLaying on the ground somewhere
  • Playing:Ragnarok Online
  • Server:Valkyrie

Posted 16 January 2012 - 12:31 PM

While I was going through OptionInfo.lua, I noticed it had 10 kilobytes of repeated lines. I removed the repeats, and then tried again.

And some of the lines were re-added.

Notably, it's only the second section of OptionInfo.lua doing this - from OptionInfoList["Trilinear"] to OptionInfoList["LockMouse"].

Now, I'm not sure exactly what this means, but hopefully this'll help find the problem. It looks to me like it's trying to add on to the end instead of actually changing what's in the file.

Edited by Thexare, 16 January 2012 - 12:32 PM.

  • 0

#18 Pres

Pres

    Too Legit To Quit

  • Members
  • 1427 posts
  • Playing:Ragnarok Online
  • Server:Yggdrasil

Posted 16 January 2012 - 02:40 PM

I think this is why it's not working:
Posted Image

After \Gravity\Ragnarok Online... there's a "\\" which is only suppose to be one \.

I have no idea how to fix that. At any rate, does anyone know KEY1 # (in UserKeys.lua) for F1-F9? :/
  • 0

#19 pikachiquita5

pikachiquita5

    Amateur Blogger

  • Members
  • 314 posts
  • Playing:Ragnarok Online
  • Server:Ymir

Posted 18 January 2012 - 04:51 PM

For those of you somehow editing the OptionInfo.lua, how do you do that? I think I tried double-clicking that, and it just said that there is no program to run the file. All this changing 0 to 1 and stuff, I have no idea how you're doing that O_o

I have just recently re-installed RO outside of the program folders, but my sound is still perma-OFF, although effects and normal chat came back on for whatever reason.
  • 0

#20 Pres

Pres

    Too Legit To Quit

  • Members
  • 1427 posts
  • Playing:Ragnarok Online
  • Server:Yggdrasil

Posted 18 January 2012 - 05:55 PM

For those of you somehow editing the OptionInfo.lua, how do you do that? I think I tried double-clicking that, and it just said that there is no program to run the file. All this changing 0 to 1 and stuff, I have no idea how you're doing that O_o

I have just recently re-installed RO outside of the program folders, but my sound is still perma-OFF, although effects and normal chat came back on for whatever reason.


Open with notepad
  • 0

#21 pikachiquita5

pikachiquita5

    Amateur Blogger

  • Members
  • 314 posts
  • Playing:Ragnarok Online
  • Server:Ymir

Posted 18 January 2012 - 06:55 PM

Open with notepad


Thanks! That's kind of retarded though, that we should have to go in with Notepads and fiddle with numbers to get the client working properly. My sound is now on =)
  • 0

#22 Pres

Pres

    Too Legit To Quit

  • Members
  • 1427 posts
  • Playing:Ragnarok Online
  • Server:Yggdrasil

Posted 20 January 2012 - 07:59 AM

Bumpp
  • 0

#23 Pres

Pres

    Too Legit To Quit

  • Members
  • 1427 posts
  • Playing:Ragnarok Online
  • Server:Yggdrasil

Posted 26 January 2012 - 12:01 PM

Bump, I'm getting tired of having to do my keys every time I log in :'[
  • 0

#24 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 27 January 2012 - 09:12 AM

Bump, I'm getting tired of having to do my keys every time I log in :'[

Get a copy of UserKeys.lua from someone with the key shortcuts done the way you want em. If you want the standard pre-renewal style layout, I can post that tonight.
  • 0

#25 Pres

Pres

    Too Legit To Quit

  • Members
  • 1427 posts
  • Playing:Ragnarok Online
  • Server:Yggdrasil

Posted 27 January 2012 - 11:42 PM

Get a copy of UserKeys.lua from someone with the key shortcuts done the way you want em. If you want the standard pre-renewal style layout, I can post that tonight.


Oh, yes, please do. That would be really helpful!
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users