Client issues in Win7 - Technical Support/Bug Reporting - WarpPortal Community Forums

Jump to content


Photo
- - - - -

Client issues in Win7


  • Please log in to reply
38 replies to this topic

#1 majinkura

majinkura

    I made it Off Topic

  • Members
  • 15 posts
  • LocationFlorida
  • Playing:Ragnarok Online
  • Server:Valkyrie

Posted 31 August 2012 - 05:16 PM

Can anyone please help me?
I'm still having trouble starting the game client since the latest patch update screwed everything up... -_-
I'm about to give up on playing entirely at this rate....

everytime i hit start on the renewal client(run as admin) i see the hourglass then it dissapears then the arrow changes to hourglas and then nothing..

i've tried everything in the stickied thread and still can't get this game to work.

the last time it was running fine was before the latest patch and on 8/17.

even when i run it in compatibility mode i get an error and the client terminates.
and when i run classic i get the error log with all the error codes.

is there something im doing wrong or should i just wait for the next maintenance??
:(


EDIT - my OS WIN7/AV - AVIRA antivirus/COMODO FIREWALL....

Edited by majinkura, 31 August 2012 - 05:36 PM.

  • 1

#2 KakyuuOuhi

KakyuuOuhi

    I made it Off Topic

  • Members
  • 31 posts
  • LocationTN, USA
  • Playing:Ragnarok Online
  • Server:Chaos Renewal

Posted 31 August 2012 - 05:33 PM

Same here. I have done just about everything: uninstalled, reinstalled, run as admin. Except classicRO gives me the error screen and the renewal client window disappears and nothing to be seen again after I hit start. I don't care to play classic, I want to play renewal. The client ran fine until the classicRO was introduced. I am VIP and have not been able to play since. My OS is Win7, AV is ESET NOD32, FW is ZoneAlarm.
ETA: No I dont use 3rd party progs, and yes I had tried disabling the AV and FW.

Edited by KakyuuOuhi, 31 August 2012 - 05:38 PM.

  • 0

#3 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 31 August 2012 - 06:11 PM

Both of you should try disabling your antivirus, and running RO. If that fixes it, turn your antivirus back on, and add an exception for RO. Several antivirus programs have recently started giving false positives for RO.

The main symptom of this behavior is that after clicking start at the patcher, the client will not open.
  • 0

#4 majinkura

majinkura

    I made it Off Topic

  • Members
  • 15 posts
  • LocationFlorida
  • Playing:Ragnarok Online
  • Server:Valkyrie

Posted 31 August 2012 - 06:16 PM

I've already tried that and it still won't work.
still gives me the hourglass icon and dissappears...
  • 0

#5 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 31 August 2012 - 06:17 PM

Anyone else got any ideas for this?
  • 0

#6 majinkura

majinkura

    I made it Off Topic

  • Members
  • 15 posts
  • LocationFlorida
  • Playing:Ragnarok Online
  • Server:Valkyrie

Posted 31 August 2012 - 06:27 PM

i even did a uninstall/reinstall..deleting the gravity folder before reinstalling..im at a total loss here =/
  • 0

#7 GoldenShura

GoldenShura

    I am New.

  • Members
  • 5 posts
  • Playing:Nothing

Posted 31 August 2012 - 07:19 PM

There´s 3 of us then.. Im having exactly the same problem that Majinkura is having
I have windows 7 too..
  • 0

#8 Sheckley

Sheckley

    Amateur Blogger

  • Members
  • 276 posts
  • LocationiRO Valk

Posted 01 September 2012 - 12:39 AM

@majinkura: Did you add the ragnarok exe's to your safe list at comodo? (http://help.comodo.c...Safe-Files.html) Most of the firewalls didn't shut down complete if you close them (on the normal way)

For example zonealarm is doing this
@KakyuuOuhi: Instead of shutting down zonealarm, try to rightclick on the task icon and select "Deactivate firewall for 5 minutes", this could solve it for you.
  • 0

#9 KakyuuOuhi

KakyuuOuhi

    I made it Off Topic

  • Members
  • 31 posts
  • LocationTN, USA
  • Playing:Ragnarok Online
  • Server:Chaos Renewal

Posted 01 September 2012 - 05:28 AM

For example zonealarm is doing this
@KakyuuOuhi: Instead of shutting down zonealarm, try to rightclick on the task icon and select "Deactivate firewall for 5 minutes", this could solve it for you.


Ok, I have tried, even checked the box, to run as admin and no change. I hit the start button on the client window and then nothing opens up... the busy cursor spins a bit, stops, then spins a bit more, then stops. I have went into my AV and added the Ragnarok Online folder, ragnarok.exe, ragexe.exe to the exclusions. Tried as you suggested to "snooze firewall for 5 mins", sadly this didn't help. I did see that "Game Mode" selection on that menu so I tried it and it didn't help either. Another thing I tried was "troubleshoot compatibility" option, when right clicking on the Ragnarok.exe, and got this funky looking window after hitting start on the game client.
Posted Image
:p_swt:

I just don't know what went wrong. ~Derpy
  • 0

#10 Sheckley

Sheckley

    Amateur Blogger

  • Members
  • 276 posts
  • LocationiRO Valk

Posted 01 September 2012 - 05:51 AM

Do you try to start ragnarok always with the compatibility option as administrator or by right clicking on the exe/link and use the option run as administrator?

Don't sure if it helps to solve this problem, I never saw this screen on any of my testing areas, but on the other hand the positive answer is: zonealarm seems not the problem. (You could try to disable the identity and data security at zonealarm, if you have enable it) (How to do: Double click on the zonealarm tray icon, click on identity and click on the button on the right at webidentitysecure (it is the first option)) EDIT: You should first restart the computer before testing.

Edited by Sheckley, 01 September 2012 - 05:56 AM.

  • 0

#11 majinkura

majinkura

    I made it Off Topic

  • Members
  • 15 posts
  • LocationFlorida
  • Playing:Ragnarok Online
  • Server:Valkyrie

Posted 01 September 2012 - 08:44 AM

Posted Image

sheckley - already done.

EDIT - ok apparently when i turn the comodo firewall off and leave my windows one on i can click start but then i get a ton of errors...

Posted Image

the last error (query region error) is looped and i end up killing it in the task manager for it to close

Edited by majinkura, 01 September 2012 - 09:03 AM.

  • 0

#12 Lynex

Lynex

    Awarded #1 Troll

  • Members
  • 802 posts
  • LocationOhio
  • Playing:Ragnarok Online
  • Server:Ymir

Posted 01 September 2012 - 09:13 AM

Use Revo Uninstaller. Uninstall RO and make sure it cleans everything out. It'll get folders and files that you wouldn't think were still somewhere on the system. Then try reinstalling RO. I've had to do it on one computer so far to get it to work. YMMV.
  • 0

#13 ZeoKenX

ZeoKenX

    Amateur Blogger

  • Members
  • 450 posts
  • Playing:Ragnarok Online

Posted 01 September 2012 - 09:22 AM

i even did a uninstall/reinstall..deleting the gravity folder before reinstalling..im at a total loss here =/


Yeah,I feel totally groped in the situation Iam in.My game works fine,but the camera involved with the mouse scroll either zooms all the way in or out,interferring with the other controls on top of that that uses the wheel and the GMs dont know whats cause that issue either.Iam a paying customer screwed I guess =/
  • 0

#14 Sheckley

Sheckley

    Amateur Blogger

  • Members
  • 276 posts
  • LocationiRO Valk

Posted 01 September 2012 - 10:34 AM

Posted Image

sheckley - already done.

EDIT - ok apparently when i turn the comodo firewall off and leave my windows one on i can click start but then i get a ton of errors...

Posted Image

the last error (query region error) is looped and i end up killing it in the task manager for it to close



This is a good signal, I got this also one time (not with comodo firewall) Did you restart (after end comodo) before you start RO? Another time I got these errors and after I end ro and start it again, it worked. I guess administrator start is not the way out of this errors, but if you didn't tried it yet (in combination with disabling comodo), you could try it (you have ragnarok installed in the default path as far as I can see)
  • 0

#15 majinkura

majinkura

    I made it Off Topic

  • Members
  • 15 posts
  • LocationFlorida
  • Playing:Ragnarok Online
  • Server:Valkyrie

Posted 02 September 2012 - 02:12 PM

just tried to run the game again...this time i got this error:

Module Name: C:\Program Files (x86)\Gravity\Ragnarok Online\Ragexe.exe
Time Stamp: 0x50298ee5 - Mon Aug 13 19:33:57 2012


Exception Type: 0xc0000005

0xffffffff

eax: 0x00a2249a ebx: 0xffffffff
ecx: 0x0018fa1c edx: 0x000000e9
esi: 0x05724ac0 edi: 0x0087a328
ebp: 0x0087a300 esp: 0x0018fa24

stack 0018fa24 - 0018fe24
0018FA24 : 00 00 00 00 C0 4A 72 05 C0 4A 72 05 00 00 00 00
0018FA34 : 28 A3 87 00 16 02 00 00 FE F2 A4 00 47 69 A1 00
0018FA44 : 6E 77 9C 00 2F 6F 73 00 C0 4A 72 05 2E 18 73 00
0018FA54 : 00 00 00 00 F8 A2 87 00 A0 37 56 00 57 BA EC E1
0018FA64 : B0 BE 5C 6B 01 00 00 00 FF FF FF FF 01 00 00 00
0018FA74 : F0 FE 18 00 D6 4E 7C 00 FF FF FF FF 55 12 7A 00
0018FA84 : C0 4A 72 05 C0 37 82 00 A3 BA EC E1 A0 AE 93 00
0018FA94 : 14 2A C2 00 88 FF 18 00 00 00 00 00 01 00 00 00
0018FAA4 : 00 00 3F 00 01 00 00 00 40 42 0F 00 E0 EF CE 02
0018FAB4 : E0 C7 CE 00 00 00 00 00 00 00 E4 02 00 00 00 00
0018FAC4 : FF 02 00 00 B4 FB 18 00 01 3C FA 76 E8 D7 CE 02
0018FAD4 : 67 6F 6F 64 00 D7 CE 02 C4 00 E4 02 C3 3C FA 76
0018FAE4 : 04 00 00 00 0F 00 00 00 10 00 00 00 96 7B 96 4A
0018FAF4 : 34 86 CD 01 37 02 98 4A 34 86 CD 01 37 02 98 4A
0018FB04 : 34 86 CD 01 00 00 00 00 00 00 00 00 00 00 00 00
0018FB14 : 46 02 00 00 73 61 76 65 64 61 74 61 00 C7 CE 02

Launch Info
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000

Job : Novice
  • 0

#16 KakyuuOuhi

KakyuuOuhi

    I made it Off Topic

  • Members
  • 31 posts
  • LocationTN, USA
  • Playing:Ragnarok Online
  • Server:Chaos Renewal

Posted 04 September 2012 - 01:29 PM

Do you try to start ragnarok always with the compatibility option as administrator or by right clicking on the exe/link and use the option run as administrator?

Don't sure if it helps to solve this problem, I never saw this screen on any of my testing areas, but on the other hand the positive answer is: zonealarm seems not the problem. (You could try to disable the identity and data security at zonealarm, if you have enable it) (How to do: Double click on the zonealarm tray icon, click on identity and click on the button on the right at webidentitysecure (it is the first option)) EDIT: You should first restart the computer before testing.


Both options with the admin are the same in a way, but yes I have tried both ways. I right click on the shortcut of renewal and run as admin, i used to just double click on it and it would run fine. Now I try right clicking on the .exe and run as admin and still the game disappears after I hit the start on the client.

When I did disable the identity and data security at zonealarm, the game looked like it was going to run. But the interface didn't have the replay button, it was the previous 3 button interface. So I tried to login, it would crash with a .lua error.

The only thing I read that I have not tried is re install the game outside the program files folder. It seemed to work for some.... im out of ideas. Sad that a lot of us are not able to play renewal but a few are able to get in the game at all... so many posts with this trouble and no attempts from the RO staff to fix this. Why won't they give a new updated client to download? The one I just DLd of the site is over a year old...

:sob: :p_sad:
  • 0

#17 majinkura

majinkura

    I made it Off Topic

  • Members
  • 15 posts
  • LocationFlorida
  • Playing:Ragnarok Online
  • Server:Valkyrie

Posted 04 September 2012 - 02:08 PM

Sad that a lot of us are not able to play renewal but a few are able to get in the game at all... so many posts with this trouble and no attempts from the RO staff to fix this. Why won't they give a new updated client to download? The one I just DLd of the site is over a year old...


I agree i mean we are missing out on all these events.
(I would have loved the double exp since im just starting out.)
:wah:

Edited by majinkura, 04 September 2012 - 02:08 PM.

  • 0

#18 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 05 September 2012 - 07:53 AM

Try uninstalling RO, and reinstalling it to a location outside of program files.

I think the closest you've come to getting it to work is when you were getting the lua errors, which happens when the game can't read the interface settings, which happens due to UAC protections on program files hiding those files from the game.

RO really shouldn't default to installing inside program files.
  • 0

#19 majinkura

majinkura

    I made it Off Topic

  • Members
  • 15 posts
  • LocationFlorida
  • Playing:Ragnarok Online
  • Server:Valkyrie

Posted 05 September 2012 - 02:08 PM

ok I will go do that now then...i hope it works this time around :p_swt:
  • 0

#20 majinkura

majinkura

    I made it Off Topic

  • Members
  • 15 posts
  • LocationFlorida
  • Playing:Ragnarok Online
  • Server:Valkyrie

Posted 27 September 2012 - 07:37 AM

well...i dunno how to get RO to install outside the programs folder...and i just reinstalled it and it went straight to programs...ran the patcher and still the client refuses to load.....
  • 0

#21 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 27 September 2012 - 09:17 AM

well...i dunno how to get RO to install outside the programs folder...and i just reinstalled it and it went straight to programs...ran the patcher and still the client refuses to load.....


Just move the RO install outside of program files (the RO folder can be moved around without problems) . There's a button you can click during the install process to choose a different location.
  • 0

#22 majinkura

majinkura

    I made it Off Topic

  • Members
  • 15 posts
  • LocationFlorida
  • Playing:Ragnarok Online
  • Server:Valkyrie

Posted 27 September 2012 - 09:26 AM

There's a button you can click during the install process to choose a different location.


where during installation??
:sob:
  • 0

#23 ilovemilk

ilovemilk

    Too Legit To Quit

  • Members
  • 3451 posts
  • LocationMilky Way
  • Playing:Ragnarok Online
  • Server:Offline

Posted 27 September 2012 - 09:36 AM

Gravity is loosing a lot of customer because of this issue.
  • 0

#24 ilovemilk

ilovemilk

    Too Legit To Quit

  • Members
  • 3451 posts
  • LocationMilky Way
  • Playing:Ragnarok Online
  • Server:Offline

Posted 27 September 2012 - 09:43 AM

Step 1. Add all the executable files into your exclusions list on your antivirus and test RO. If no good try disabling your antivirus any third party firewall software completely. Still no good? Proceed to step 2.

Step 2. With your antivirus/firewall turned off. Run the patch client as administrator by going to C:\Program Files\Gravity\Ragnarok\Ragnarok.exe. Right click on the Ragnarok.exe client and select Run As > Administrator.
Test RO. If no good proceed to step 3.

Step 3. If you are spending way too much time trying to fix it then I would strongly suggest a complete uninstall and reinstall. The trick with the newer Windows operating systems is to always Run the setup file, configuration file, or first time running RO as admin. The secret is run as Admin. Even when it comes to installing or reinstalling.
Once you have completely uninstalled RO. Proceed to reinstalling the game using the RO setup file. During the installation prompts look for a folder or destination path. Change the folder path to your Desktop or My Documents.
Patch the game using Run As mentioned in 'Step 2.' Test RO after reinstallation. If no good proceed to step 4.

Step 4. Have a beer. Go explorer real world maps and talk to real girls. Make friends, money, have a lot of sex, laugh, and be happy. Profit.
  • 0

#25 Lynex

Lynex

    Awarded #1 Troll

  • Members
  • 802 posts
  • LocationOhio
  • Playing:Ragnarok Online
  • Server:Ymir

Posted 27 September 2012 - 10:00 AM

I can't understand how so many people are having issues running this game, let alone in Windows 7. I've got it installed on 8 different computers and I have NO problems on any of the installs. (Most on Win 7, a few on XP and one Vista)

Default Install folder, SP1, Ran (ro.exe and setup.exe) as Admin and in SP3 Compatibility Mode. No Additional Firewall installed and only using MSE as my AV.




For those of you running a secondary firewall: Why are you running a secondary firewall? Windows Firewall actually does a good job. Drop your -_- Firewall software and stick to your Router and Windows Firewall.

Test an install on another computer or laptop, its not like RO has the same requirements as Crysis did or GTA4 does. It'll run on nearly anything.

Does it work on that computer? Oh it does!? What isn't installed on this one that is on the problem computer?

Barring that: UNINSTALL YOUR ANTIVIRUS AND TRY INSTALLING AND / OR RUNNING RO AGAIN. Does it work? If not, you're only out a few moments time of having to reinstall your AV.
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users