Running Ragnarok Online on Windows Vista/Windows 7/Windows 8 - Technical Support/Bug Reporting - WarpPortal Community Forums

Jump to content


Photo
- - - - -

Running Ragnarok Online on Windows Vista/Windows 7/Windows 8


  • Please log in to reply
209 replies to this topic

#1 Ultimate

Ultimate

    Ultimate Event Inventor

  • Members
  • 2412 posts
  • LocationValhalla Dwarf NPC
  • Playing:Ragnarok Online

Posted 05 August 2010 - 06:51 AM

Common Issues with Ragnarok Online on Windows Vista/Windows 7

Ragnarok Online (RO), as with many pre-2012 games, can sometimes have problems when used on a machine running Windows Vista or Windows 7.

This thread may help you address the following common problems:
1) When you load RO you receive the error "Failed to write [name of patch]" or "Failed to extract [name of patch]."
2) When you load RO you receive a message on the title screen "Sprite Error 242342354"

Option 1:
After installing RO, right click the shortcuts and set them to run as admin. Merc/homun AI won't work in this configuration, but a working install using this option can simply be moved to another location (ex: C:/games)

Option 2:
Install RO to a location that is not protected (IE, outside of program files - ex: C:/games etc).
Then, if needed, set the shortcuts to run as admin. It shouldn't be needed but some users still encounter problems.

NOTE: C:\GAMES\WARPPORTAL IS NO LONGER THE DEFAULT INSTALLATION DIRECTORY FOR YMIR SERVER...now it is back to Program Files :|

Option 3:
Run RO in an appropriate compatability mode (described below).

Option 4:
If nothing else works, turn off UAC.
Spoiler


When you install RO, you may also follow the above process to have the installer run as an administrator as well.

I downloaded the Ragnarok Setup, and when I went to open it, it didn't work. BTW I'm using Vista. Anyways I open the program, and it never actually opens. My window freezes and the setup never starts....



If you encounter a sprite error on the title screen:

You missed a patch, either through bad luck, or UAC causing duplicate data files to get out of sync.

Sprite error on title screen should be treated like any other sprite error - it's due to a mispatch of some sort.
It _might_ be fixed by running as admin (if only the virtualized data files are incomplete, which seems to happen more), but if that fixes it, make sure you set RO to always run as admin. I don't really feel like typing out the whole rant about how UAC is acting oddly here.


Garbage, scanlines, or resolution issues:
If you have an ATI card, many users report a blank, black, or otherwise disrupted image when launching RO (usually on full screen). Make sure you have the most up-to-date driver from the ATI Catalyst resource page. If you have an older graphics card that has been discontinued from support, then you might have to install old drivers on Windows 7 using different compatibility modes on the setup package. But that is a different can of worms.

You can try right clicking the Ragnarok.exe file in the Gravity folder, going to "Properties" then selecting "Compatibility." From there you can try setting the compatibility to some version of Windows XP (Service Pack 2 or 3).

Edited by Ultimate, 10 January 2013 - 02:06 PM.

  • 0

#2 DrAzzy

DrAzzy

    Azzylike

  • Ragnarok Moderator
  • 14783 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 05 August 2010 - 06:57 AM

UAC does not, as far as I am aware, cause "failed to get" errors. Every post about a failed to get error that i've read within the past month was about people patching up for the first time, and having patching fail to "Failed to get" on a random file. Plenty of them were using XP. "Failed to get" indicates network problems, while "failed to write" are permission problems (i think there's also a "failed to extract" or something that can occur due to permission problems).

Also, one thing to never do: NEVER rightclick RO and run it as admin, and then go back to running in normally. Running as admin only when you got patch errors, and running normally otherwise will eventually destroy your RO install.


Sprite error on title screen should be treated like any other sprite error - it's due to a mispatch of some sort.
It _might_ be fixed by running as admin (if only the virtualized data files are incomplete, which seems to happen more), but if that fixes it, make sure you set RO to always run as admin. I don't really feel like typing out the whole rant about how UAC is acting oddly here.

Edited by DrAzzy, 05 August 2010 - 07:00 AM.

  • 0

#3 Ultimate

Ultimate

    Ultimate Event Inventor

  • Members
  • 2412 posts
  • LocationValhalla Dwarf NPC
  • Playing:Ragnarok Online

Posted 07 September 2010 - 07:37 AM

"Failed to Get" Errors

Scope:

On a new client installation, many users report that the patch client will fail on a random file (different file each time), giving a "failed to get" error, and due to the long period of time that it takes to patch, this can make trying to get through patching a very time consuming and frustrating process.
The key bit of idiocy here is that the patch client will apply patches as it downloads them, but only record that it has downloaded and applied the patches at the END of the patch process. So if you patch 99 out of 100 files, and the download of the last file errors, next time you have to dowload all 100 files again, despite that 99 of them have already been applied. This method "locks in" the patches that you've done.


This method is ABSOLUTELY NOT TO BE USED in any of these circumstances:
You receive a "Failed to write" error - this is a permissions issue, see the other threads on vista/windows 7/UAC problems.
You receive a "Failed to get" error on the SAME FILE every time you try to patch.
You are using windows7 or vista and have not followed instructions (available ad nauseum in other threads) to make RO work with windows 7/vista.
When the patcher cannot download any file (ie, it cannot connect at all, or errors on the first file it tries to download)

This method is ONLY APPLICABLE TO FIXING NEWLY INSTALLED CLIENTS or CLIENTS THAT HAVE NOT BEEN PATCHED IN MANY MONTHS and are receiving "Failed to get" errors on A DIFFERENT FILE EACH TIME THE PATCH CLIENT IS RUN.

Procedure:

1) Start the RO that you have the issue on (valk or prem). When it gives an error, write down the file that it got the error on.

2) Download the hex editor, XVI32 http://www.chmaas.ha...xvi32/xvi32.htm, and extract it (it doesn't need to be installed). Others will work, but may call features different things. This is what I use, and hence why i recommend it.

3) Start -> Run -> "notepad" (this starts notepad as admin on 7/vista, so it will see the correct version of the file). Open patch2.txt in your RO folder. You will see a long list of file names, and numbers associated with them. Find the file that you got the error on. Write down the 4 digit number on the line BEFORE the file that you got the error on - NOT THE NUMBER OF THE FILE YOU MISSED, THE NUMBER OF THE FILE BEFORE THE ONE YOU MISSED.

4) Run XVI32 as admin, and open patch.inf in the RO folder (for valkyrie, fpatch.inf).

5) Leave the first byte selected, tools -> encode number. Enter the number you recorded in step 3. Select "longint - 4 byte" and "overwrite". Press okay. Save the file.

6) Exit XVI32 and notepad, and run the patcher. It will start patching with the file that failed last time. If you get another error later in the process, return to step 1.

Disclaimer:
The procedure above is accurate and works as specified to the extent of my knowledge.
That said, I take no responsibility for problems of any kind that may occur as a result of following this procedure incorrectly. Or even from following it correctly.
Please always act in accordance with the Terms of Service - do not hex edit stuff you're not supposed to


Edited by Ultimate, 16 September 2010 - 09:38 AM.

  • 0

#4 Ultimate

Ultimate

    Ultimate Event Inventor

  • Members
  • 2412 posts
  • LocationValhalla Dwarf NPC
  • Playing:Ragnarok Online

Posted 10 September 2010 - 03:53 AM

I did this and it made my screen gigantic. I'm on a widescreen 1600x900 (and it was set for that on both Rag and my comp), anyone know if that makes any difference? Still not sure if it helped the black seizure bars because I was so distracted by the zoom XD

All I know is that it worked on my crappy old comp with Windows XP and now I have Windows 7 and Rag it giving me a headache. That'll learn me to upgrade :o


got time for remote assistance? pm me your MSN details if so
  • 0

#5 Hirami

Hirami

    I am New.

  • Members
  • 1 posts

Posted 23 September 2010 - 03:38 AM

Umm..i just dowload RO..and my comp is Window Vista..i already do what Ultimate said..but when i want to open the file it says 'blablabla and exe.is not a valid Win32 application.'What is win Win32 ? do i need to install something?or need code? huhuhu T^T :)

Edited by Hirami, 23 September 2010 - 03:40 AM.

  • 0

#6 DrAzzy

DrAzzy

    Azzylike

  • Ragnarok Moderator
  • 14783 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 23 September 2010 - 07:22 AM

Umm..i just dowload RO..and my comp is Window Vista..i already do what Ultimate said..but when i want to open the file it says 'blablabla and exe.is not a valid Win32 application.'What is win Win32 ? do i need to install something?or need code? huhuhu T^T :)


Installer is corrupted. Delete and redownload. Do not use any sort of "download accelerator" or "download manager" program, those are notorious for mangling the files they download.
  • 0

#7 BronxDevil

BronxDevil

    I made it Off Topic

  • Members
  • 65 posts

Posted 04 October 2010 - 10:43 AM

i just downloaded RO last night and been trying to patch it ever since it starts up says attepting to connect to file server. then it says failed to get 2010-7-8 data_gm.gpf file.

ive tried everything it says to try here in this topic cuz im running on windows vista and nothing has worked still same prob over and over

Edited by BronxDevil, 04 October 2010 - 10:44 AM.

  • 1

#8 HTL2001

HTL2001

    I made it Off Topic

  • Members
  • 92 posts
  • LocationNJ

Posted 04 October 2010 - 04:00 PM

The patcher is something different

Someone was noting that you can get the files from the FTP manually, by setting the ftp client to NOT go into passive mode. I think the recent forum problems were being caused by some sort of DDoS attack and their firewall modifications started messing with the patcher
  • 0

#9 jspr11432

jspr11432

    I am New.

  • Members
  • 1 posts

Posted 08 October 2010 - 02:35 PM

everything is working except when i try to log in it says i have run out of paid playing time. what does this mean?
  • 0

#10 Slyfer

Slyfer

    I am New.

  • Members
  • 3 posts

Posted 09 October 2010 - 06:55 PM

Posted Image


Whats happening here? i just installed it and i apparently cant open it on my Windows 7, but it does work on vista. Tried to run as Vista and XP, but neither work. Could i get some help here, please?
  • 0

#11 Slyfer

Slyfer

    I am New.

  • Members
  • 3 posts

Posted 11 October 2010 - 07:02 PM

Posted Image


Whats happening here? i just installed it and i apparently cant open it on my Windows 7, but it does work on vista. Tried to run as Vista and XP, but neither work. Could i get some help here, please?



crap, i forgot i had to translate it. It says something about it failed to start the aplication because the pararel configuration its wrong. That i should check the event log of the aplication or use the tool called sxstrace.exe of the command chain to obtain more details.

Please halp
  • 0

#12 DrAzzy

DrAzzy

    Azzylike

  • Ragnarok Moderator
  • 14783 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 21 October 2010 - 10:01 AM

everything is working except when i try to log in it says i have run out of paid playing time. what does this mean?

It means you're using the premium server client, when you're trying to connect to the free server (or you're trying to connect to the premium server, but havn't bought a subscription). You want Valkyrie/RagnarokFree, not Ragnarok or Ragnarok Renewal.

Slyfer, that's a strange one, no clue.
  • 0

#13 pomdjyer

pomdjyer

    Amateur Blogger

  • Members
  • 167 posts

Posted 22 October 2010 - 07:47 AM

ever since i got W7, my screenshoots are black & white and all weird, might be because of my graphic card or something, but if u know about a fix that'd be cool
  • 0

#14 tone

tone

    I made it Off Topic

  • Members
  • 10 posts

Posted 24 October 2010 - 09:01 AM

I'm actually having the screenshot problem too. I did notice that it only occured when I ran the game in full screen on my laptop's max resolution (1366x768), and if I ran it at say 1280x720, or in a lower res windowed mode, there were no problems at all. Only issue with running the game in a lower resolution is that the text and sprites are kinda blurred, and it's a real eyesore to look at. Is there a fix for this?
  • 0

#15 antikv

antikv

    Too Legit To Quit

  • Members
  • 1285 posts

Posted 24 October 2010 - 10:48 AM

i have the screen shot problem too...and i have the w7
  • 0

#16 tone

tone

    I made it Off Topic

  • Members
  • 10 posts

Posted 08 November 2010 - 09:12 AM

So is there an actual fix for the screenshot issue, or am I stuck running RO in a low-res window for taking screens?
  • 0

#17 DrAzzy

DrAzzy

    Azzylike

  • Ragnarok Moderator
  • 14783 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 08 November 2010 - 10:02 AM

So is there an actual fix for the screenshot issue, or am I stuck running RO in a low-res window for taking screens?


No, there is no fix other than changing the resolution.

The fix is to run RO at the 4:3 aspect ratio. That is the aspect ratio that God intended people to use, before greedy monitor manufacturers and hollywood heretics deceived the consumers of the world into beliving that widescreen monitors were better. Return to the True Path, and your troubles will vanish, and when your time has come to leave this world, you will live for eternity in a high-resolution paradise, while the wide-screen using heretics will be forever forced to use vertical scroll bars (in hell, the monitors are 4096x128, and they run Win7 with the default UI, so you can barely get 1 line of text in, after the task bar and title bar). Repent! Repent!

Edited by DrAzzy, 08 November 2010 - 10:06 AM.

  • 1

#18 tone

tone

    I made it Off Topic

  • Members
  • 10 posts

Posted 08 November 2010 - 12:01 PM

I'd run it in a different resolution if the game didnt hurt my eyes when fullscreened (sprites and graphics are ok, but the blurry text gets headache inducing), looks like im screwed unless this ever gets patched -_-
  • 0

#19 LtVern

LtVern

    I am New.

  • Members
  • 5 posts

Posted 13 November 2010 - 06:16 PM

I'm having issues with downloading RO, but my issue isn't on here. When I download the free client and when it gets done, I click on it, get the run program thing, then it says, "This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package." So.. what do I do lol
  • 0

#20 DrAzzy

DrAzzy

    Azzylike

  • Ragnarok Moderator
  • 14783 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 15 November 2010 - 10:06 AM

I'm having issues with downloading RO, but my issue isn't on here. When I download the free client and when it gets done, I click on it, get the run program thing, then it says, "This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package." So.. what do I do lol


Installer is getting corrupted or DL is not completing. Try DL from irowiki.org/wiki/Clients_and_Patches

I'd run it in a different resolution if the game didnt hurt my eyes when fullscreened (sprites and graphics are ok, but the blurry text gets headache inducing), looks like im screwed unless this ever gets patched :unsure:

Could run windowed at the highest res that works, and set the task bar to not be always-on-top so that you can use the full screen height.

Edited by DrAzzy, 15 November 2010 - 10:09 AM.

  • 0

#21 kiddomaddo

kiddomaddo

    Amateur Blogger

  • Members
  • 498 posts
  • Playing:Nothing

Posted 18 November 2010 - 07:50 AM

Hello.

I have a problem with the game. It patches perfectly but once I enter my username and password, I get the error "Failed to connect to server". This problem started a week back. My first reaction was to uninstall and re-download of the game. I did that twice but that didn't fix anything. The other online/mmo's games work perfectly fine.
I connect through the university internet which has a couple of ip addresses and we are behind a NAT router probably from what i can gather. Which means that the ip addresses assigned are also dynamic per session probably.
I cannot figure out why would the game suddenly stop connecting. Before I start playing with proxys n ports, I would like to know if there is any other reason why I wouldn't be able to connect.
Your help would be highly appreciated.
Thank you.

PS: I asked my friends to log in on my accounts and that works perfectly fine.
  • 0

#22 ForsakenArcher

ForsakenArcher

    I am New.

  • Members
  • 9 posts

Posted 20 December 2010 - 12:56 AM

Hi you commented on my post last time... im stuck on part 3 what do you mean by 4th part of the line what??


Write down the 4 digit number on the line BEFORE the file that you got the error on - NOT THE NUMBER OF THE FILE YOU MISSED, THE NUMBER OF THE FILE BEFORE THE ONE YOU MISSED.

That

Edited by ForsakenArcher, 20 December 2010 - 12:57 AM.

  • 0

#23 Rodart

Rodart

    I am New.

  • Members
  • 1 posts

Posted 10 January 2011 - 04:12 PM

Hi!
I´m using windows 7 and I just downloaded RO and when I open it it sais that i'm out of available playing paid time. game will shut down automatically.
  • 0

#24 Beardyville

Beardyville

    I am New.

  • Members
  • 2 posts

Posted 19 February 2011 - 04:39 PM

heyy guys, so i just installed iRO 13.2 installer but when I try to play it, it says "This installation package could not be opened. contact the application vendor to verify that this is a valid Windows installer package." what do I do? and by the way, im using windows7

thanks :Emo_12:)
  • 0

#25 Lorderagon

Lorderagon

    I made it Off Topic

  • Members
  • 73 posts
  • Playing:Ragnarok Online

Posted 08 April 2011 - 09:12 AM

heyy guys, so i just installed iRO 13.2 installer but when I try to play it, it says "This installation package could not be opened. contact the application vendor to verify that this is a valid Windows installer package." what do I do? and by the way, im using windows7

thanks -_-)


post a screenshot of the message
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users