AzzyAI 1.551 NEW FIX 11/5 ! - Page 7 - Homunculus Headquarters - WarpPortal Community Forums

Jump to content


Photo
* * * * * 4 votes

AzzyAI 1.551 NEW FIX 11/5 !


  • Please log in to reply
229 replies to this topic

#151 Akilez

Akilez

    Too Legit To Quit

  • Members
  • 1701 posts
  • LocationGuadalajara, Mexico
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 04 November 2015 - 02:25 AM

Hello, I am running AzzyAI 1.54 on a Windows 10 machine.  I get an error that reads:

 

./AI/USER_AI/AzzyUtil.lua:744: bad argument #2 to 'GetV' (number expected, got nil).

 

The situation is that I'm in Nifflheim town with my Homunculus out (set to Ignore in Default tactics, since I don't want my homu attacking monsters), and any time I or it is approached by a monster (Gibbet, Quve, etc), the error pops up.  Pretty much freezes my client until I hit OK on the dialog, and will happen with every monster swing.

 

Guessing there's some issue with the homu being in combat in a town?  Either way, think it needs a fix.  Would provide a screen, but I'm not familiar with how to upload images here.

 

Thanks.

 

Upgrade it to 1.551, go to the 1st page of this thread, then follow the instructions :)


  • 0

#152 Fijas

Fijas

    I made it Off Topic

  • Members
  • 32 posts

Posted 04 November 2015 - 02:56 AM

I did - the GUI shows 1.54 though in the "About" section.

 

As for the bug above, I think I narrowed it down to selecting "React (Any)" in the Default tactics.  When I change React to "React to Casts", the issue seems to go away.

 

Might be good to look at.


  • 0

#153 Akilez

Akilez

    Too Legit To Quit

  • Members
  • 1701 posts
  • LocationGuadalajara, Mexico
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 04 November 2015 - 02:00 PM

I did - the GUI shows 1.54 though in the "About" section.

 

As for the bug above, I think I narrowed it down to selecting "React (Any)" in the Default tactics.  When I change React to "React to Casts", the issue seems to go away.

 

Might be good to look at.

 

Oh, lol, i had the same issue hahah with such particular option


  • 0

#154 armourer84

armourer84

    Amateur Blogger

  • Members
  • 422 posts

Posted 05 November 2015 - 06:07 PM

Hi

 

My Homun is Lif -> Eira.

 

Please let me know.

 

1. How to use Eira's Silent Breeze on the owner. How to set the function.

- I've already set Breeze on the owner funtion as enabled and autohealed enable and UseSilentBreeze as true. Of coarse, I've set then turn on and off with any possibility and the outcome does not let the Eira use this skill on her own.

 

2. How to use Overboost continuously.

- I'd like to let my Eira be overboosted all the time. I've set the UseOverboost as ASAP but when the Overboost casting is interrupted. the cycle of auto-overboost is gone forever. I need to relog the client to resume this. I've tried idle and chase option and both result the same when the cast is interupted.

 

Thanks in advance.

 


1. That should work, not sure what's wrong. I don't have Eira to test on, nor do I really have time. Do you have the owner heal threshold set correctly and all? It's not a vani -> eira is it?

 

2. It will pick back up when overboost would have run out. I try to detect when the skill fails, but we get very little feedback about when a skill fails, though. I can usually guess if you've gained some SP a few times from natural regen, and aren't at full HP when the cast happens, and if I detect the cast being broken in that way, I recast it. But there's no good way to test whether the cast was successful. 

 

1. When I set autoheal->on , my Eira try to cast Healing Hand even I was not carrying any Red-slim. The value I set in AI is to heal when HP 90% and set it to autoheal off but healsilencebreezeowner on. Casting Silence breeze manually is special. It should to hold shift key to activate it on owner or other allies likes Healer try to damage undead with Healing spell.

 

2. To fix the interrupted Overboost, I also cast it manually BUT this is useless because autocasting Overboost should be done when the owner AFK. I think the code on ASAP will trigger when the status with the spell ended but this is not correct because the it can be interrupted. If the spell interupted, it will have no trigger point when the effect end and if there is not point the effect end, the recast will not be triggered. The correction is make the AI checking the state if it has the effect or not. If it doesn't have Overboost effect, it should recast it if possible. If it is not possible to check the effect status when it is idle, I think it is possible to check the status effect when any other status effects end on owner or itself OR any action that AI assign it to do.

Btw, I dont understand "I can usually guess if you've gained some SP a few times from natural regen, and aren't at full HP when the cast happens, and if I detect the cast being broken in that way, I recast it.". I don't what you do mean and which is stand for Owner, Homun or AI?

When Overboost spell is interrupted, the HP state of owner usually full. The SP of owner maybe full if the interrupted casting is the 1st time Eira try to cast. (when Overboost effect end, it consume 50% max sp from owner makes autocasting overboost will drain owner's SP out while AFK or not.)


Edited by armourer84, 05 November 2015 - 06:16 PM.

  • 0

#155 Valadez

Valadez

    Amateur Blogger

  • Members
  • 372 posts
  • Playing:Nothing

Posted 06 November 2015 - 05:29 AM

Been having problems setting custom routes, both for Mercenary following and Homunculus resting.

 

I frequently get this error.

./AI/USER_AI/AI_main.lua:2884: attempt to concatenate local 'step' (a nil value)

At first I thought maybe I wasn't setting my Merc route properly but then I had the error occur with a basic Relativeroute for my Homun. I had him set to use this.

MyRoute={{-8,-8},{-8,0},{-8,8},{0,8},{8,8},{8,0},{8,-8},{0,-8}}

But it throws the error when it reaches -8,0.

 

I then tried the heart shaped route you put in your documentation but even that throws an error under certain circumstances. It succeeds with the route normally but if I send him out to the west when he returns to do the route it throws the error.

 

EDIT: Nothing appears in the error log about it.

 

EDIT2: These all occur with the ROUTE_CIRCLE setting. I haven't tried ROUTE_LINEAR. Also I've just realised that almost every time I've had this error happen my Merc/Homun has been to the west of me. Might be coincidence but thought it was worth mentioning.


Edited by Valadez, 06 November 2015 - 05:33 AM.

  • 0

#156 renouille

renouille

    Too Legit To Quit

  • Public Security Section 9
  • 2446 posts
  • LocationUS
  • Playing:Ragnarok Online
  • Server:renewal

Posted 06 November 2015 - 06:31 AM

local distance=math.sqrt((v[1]-posx)^2+(v[2]-posy))
I think that should be:
local distance=math.sqrt((v[1]-posx)^2+(v[2]-posy)^2)

  • 1

#157 Valadez

Valadez

    Amateur Blogger

  • Members
  • 372 posts
  • Playing:Nothing

Posted 06 November 2015 - 03:06 PM

That has done it. Thanks so much renouille! 


  • 0

#158 charta

charta

    I am New.

  • Members
  • 1 posts

Posted 13 January 2016 - 06:50 PM

im playing at limit-ro

Dopple Merch wont attack anyone, even the aggresive one. it just stand still. AzzyAI 1,551, on Windows XP,

already copy azzyAI both AI and AI_Sakray folder

AAIStartM.txt :

AzzyAI (hom) version 1.54
Main version:1.550
AzzyUtil version:1.552
Constant version:1.55
Config: Custom, edited 1/12/2016 3:13:22 PM
Tactics: Custom, edited 1/12/2016 3:13:22 PM
Time: 01/12/16 15:21:57
Lua VersionLua 5.1
Error: File version errorAI has been modified to use the ranged pierce exploit, this may be illegal on the RO you play, contact your game administrators if you are unsure. AzzyUtil.lua wrong version 1.55
Const_.lua wrong version 1.55
AI_main.lua wrong version 1.55

 

i cant post jpg here, so i put it on dropbox

https://www.dropbox....yAI 01.jpg?dl=0

https://www.dropbox....yAI 02.jpg?dl=0

https://www.dropbox....yAI 03.jpg?dl=0

total 3 jpg

 


  • 0

#159 Liliadent

Liliadent

    I am New.

  • Members
  • 1 posts

Posted 15 January 2016 - 03:04 PM

Same here. Does not work on me. I installed it correctly also got the AAIStartH.txt. But the homunculus just stand and do nothing even he is getting agro.


  • 0

#160 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 16 January 2016 - 03:29 PM

Per FAQ, AzzyAI is not compatible with illegal private servers. 

 

Thanks Ren, that is fixed in github version as of now.


Edited by DrAzzy, 16 January 2016 - 03:32 PM.

  • 0

#161 Aruvian13

Aruvian13

    I made it Off Topic

  • Members
  • 12 posts
  • LocationHeroes City Indonesia
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 31 January 2016 - 04:35 AM

I tried to leveling my homun in ant hell, but my amistr didn't attack ant
It always work fine to another monster whatever it's aggressive or not aggressive, but just ant amistr din't want to attack

I don't know why and how to fix it? I use latest update of AzzyAi
thx b4 and sorry for bad english


  • 0

#162 Reaghann

Reaghann

    Amateur Blogger

  • Members
  • 347 posts
  • Playing:Ragnarok Online
  • Server:pRO New Chaos, iRO Thor

Posted 01 February 2016 - 07:58 AM

I tried to leveling my homun in ant hell, but my amistr didn't attack ant
It always work fine to another monster whatever it's aggressive or not aggressive, but just ant amistr din't want to attack

I don't know why and how to fix it? I use latest update of AzzyAi
thx b4 and sorry for bad english

 

On your AzzyAI Configuration Utility window, click on "Homunculus Tactics" tab. You should see a list of monsters on the left side column. Look up for the ant monsters in Ant Hell (Andre, Pierre, Deniro, Vitata, etc.),click on them and set the Basic Behavior to anything but "Tank" or "Ignore". If you want your homunculus to be highly aggressive towards them, set it to "Attack (High)".


  • 0

#163 doomdeL

doomdeL

    I am New.

  • Members
  • 1 posts

Posted 09 February 2016 - 12:44 PM

hi guys,

 

good day. i started playing iPlay RO since last Dec. and I've created an alchemist just last week...this is my first time as an alchemist, and i wanted to use different homunculus AI...so i followed the instructions on the page 1 of this thread, everything seems to work fine, but i noticed that my homunculus is just patrolling around my character, it didn't attack either melee nor use skills, but i set everything in the AzzyConfig.exe, i even double check the configuration settings with the "documentation.pdf"

 

i believe my homunculus was a Vanilmirth...

 

can anyone help me resolve this issue?

 

TIA


Edited by doomdeL, 09 February 2016 - 12:46 PM.

  • 0

#164 KerSmack

KerSmack

    Amateur Blogger

  • Members
  • 144 posts

Posted 10 February 2016 - 07:15 PM

Hey i just had a simple question, i have talked to a lot of Gene's and they all say they use this AI and it is really good. I was wondering this AI was set up to KS from others? It might sound like a weird question but i see a lot on homu's KSing from players along with other pets and Mercs. I do know that KSing is on the Terms of Service of the game as a banable offence but i see it happen so often it just doesnt seem like people care.

 

Any feed back would be great Thanks in advance. ( i just wanted to know b4 i use this AI tho 80% of ppl i talk to use it already ).


  • 0

#165 Valadez

Valadez

    Amateur Blogger

  • Members
  • 372 posts
  • Playing:Nothing

Posted 11 February 2016 - 10:41 AM

Hey i just had a simple question, i have talked to a lot of Gene's and they all say they use this AI and it is really good. I was wondering this AI was set up to KS from others? It might sound like a weird question but i see a lot on homu's KSing from players along with other pets and Mercs. I do know that KSing is on the Terms of Service of the game as a banable offence but i see it happen so often it just doesnt seem like people care.

 

Any feed back would be great Thanks in advance. ( i just wanted to know b4 i use this AI tho 80% of ppl i talk to use it already ).

 

It can be, it's configurable.


  • 0

#166 Akilez

Akilez

    Too Legit To Quit

  • Members
  • 1701 posts
  • LocationGuadalajara, Mexico
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 12 February 2016 - 05:04 AM

Hey i just had a simple question, i have talked to a lot of Gene's and they all say they use this AI and it is really good. I was wondering this AI was set up to KS from others? It might sound like a weird question but i see a lot on homu's KSing from players along with other pets and Mercs. I do know that KSing is on the Terms of Service of the game as a banable offence but i see it happen so often it just doesnt seem like people care.

 

Any feed back would be great Thanks in advance. ( i just wanted to know b4 i use this AI tho 80% of ppl i talk to use it already ).

 

If you are going to be AFK i would suggest to set up KS, otherwise, non-bots players will KS anyway hahaha


  • 0

#167 Reaghann

Reaghann

    Amateur Blogger

  • Members
  • 347 posts
  • Playing:Ragnarok Online
  • Server:pRO New Chaos, iRO Thor

Posted 13 February 2016 - 04:26 AM

hi guys,

 

good day. i started playing iPlay RO since last Dec. and I've created an alchemist just last week...this is my first time as an alchemist, and i wanted to use different homunculus AI...so i followed the instructions on the page 1 of this thread, everything seems to work fine, but i noticed that my homunculus is just patrolling around my character, it didn't attack either melee nor use skills, but i set everything in the AzzyConfig.exe, i even double check the configuration settings with the "documentation.pdf"

 

i believe my homunculus was a Vanilmirth...

 

can anyone help me resolve this issue?

 

TIA

 

 

Tell us what map do you go to level your homunculus, it might be helpful for people to know what could be the problem. But generally, you gotta check specific mob entry on your Homunculus Tactics tab. You should see a list of monsters on the left side column. Look for the mob entry corresponding to the monsters on the map you are in and see if the Basic Behavior is set to Attack (High), Attack (Medium) or Attack (Low). If not, set it yourself (check the mob ID at http://db.irowiki.org/db/). Attack (High) = highly aggressive towards monsters. Monsters not in the list follow the Default mob entry (topmost of the list). On the other hand, if you want to stop your homunculus to walk around you, set the UseIdleWalk to None on your Homunculus Tab.

 

Edit:

I thought it was a typographical error due to spacing but after googling the Ragnarok server you indicated in your post, I learned it is a private server which explains why you encounter these problems. DrAzzy, the author of AzzyAI, mentioned that it doesn't work with private servers such as the one you are playing. See this post from DrAzzy.

 

Spoiler

 

 

 

Hey i just had a simple question, i have talked to a lot of Gene's and they all say they use this AI and it is really good. I was wondering this AI was set up to KS from others? It might sound like a weird question but i see a lot on homu's KSing from players along with other pets and Mercs. I do know that KSing is on the Terms of Service of the game as a banable offence but i see it happen so often it just doesnt seem like people care.

 

Any feed back would be great Thanks in advance. ( i just wanted to know b4 i use this AI tho 80% of ppl i talk to use it already ).

 

You can set whether you want your homunculus to KS or not. I observed most homunculi are set to KS and it depends on the situation because sometimes if you don't do that, someone will steal your mob. If you got complains, just apologize and explain why you need to turn on KS mode. I'm sure they will understand. However, there may be one instance you are surrounded by non-KS homunculi, that's the time you turn it off.


Edited by Reaghann, 13 February 2016 - 04:50 AM.

  • 0

#168 lislis1

lislis1

    I made it Off Topic

  • Members
  • 90 posts
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 13 February 2016 - 06:29 AM

hello. idk this issue already already answer or not.

i just want to know. after im uprated this 1.551, my homun goes atk, after mob get killed, he get back to me. and then go atk the other one. it just make my homun slow kill. 

which one the setting is that?

 

thanks!


  • 0

#169 Narayana

Narayana

    I am New.

  • Members
  • 5 posts

Posted 13 February 2016 - 07:33 AM

Not part of the question but I tried updating to 1.551 but it still says 1.54 so i assume i had the updated version all along, i saw it confused some other people as well after updating and looking through posts :P

But is there some way to make my filir only cast moonlight lv1? Basicly lv1 does the most damage per sp so i figured i would just want him to spam lv1, but i already leveled it to lv5 to test out the damage outputs and stuff for myself, so did i screw myself over by doing that? >__<


  • 0

#170 lislis1

lislis1

    I made it Off Topic

  • Members
  • 90 posts
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 13 February 2016 - 09:51 AM

Not part of the question but I tried updating to 1.551 but it still says 1.54 so i assume i had the updated version all along, i saw it confused some other people as well after updating and looking through posts :P

But is there some way to make my filir only cast moonlight lv1? Basicly lv1 does the most damage per sp so i figured i would just want him to spam lv1, but i already leveled it to lv5 to test out the damage outputs and stuff for myself, so did i screw myself over by doing that? >__<

after i upgrade the latest one, i got same issue like this.

i dont know where is the setting. my vanil use lvl low of bolt. before this, he wait untill got some SP and do a max lvl skills.

it is really worst things. 


  • 0

#171 RodoDaft

RodoDaft

    I made it Off Topic

  • Members
  • 36 posts
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 27 February 2016 - 05:52 PM

Hello, i just return again and download AI but my homun don't attack, i try with others updates and use /hoai but say this.

"cannot open ./AI/USER_AI/AI.lua: no such file or directory"

what i need to do? :C

 


  • 0

#172 FenrirV01

FenrirV01

    Amateur Blogger

  • Members
  • 150 posts
  • Playing:Ragnarok Online
  • Server:Thor

Posted 27 March 2016 - 10:04 PM

hello guys, i'm sorry i'm noob at these things. i recently downloaded this:

 

Download AzzyAI 1.551

 

and tried tweaking AzzyAIConfig.exe for my vanilmirth to use caprice, but it still doesn't use caprice :hmm:  can you pinpoint what value should i replace for it to use caprice? :ani_swt3: thanks for future help


  • 0

#173 Reaghann

Reaghann

    Amateur Blogger

  • Members
  • 347 posts
  • Playing:Ragnarok Online
  • Server:pRO New Chaos, iRO Thor

Posted 28 March 2016 - 02:36 AM

hello guys, i'm sorry i'm noob at these things. i recently downloaded this:

 

Download AzzyAI 1.551

 

and tried tweaking AzzyAIConfig.exe for my vanilmirth to use caprice, but it still doesn't use caprice :hmm:  can you pinpoint what value should i replace for it to use caprice? :ani_swt3: thanks for future help

 

Vanilmirth uses Caprice lvl 5 by default, no tweaking needed. What level is your homunculus and its total/max SP? It won't be able to use Caprice on early levels unless the SP suffice the mana requirement for the skill.


  • 0

#174 FenrirV01

FenrirV01

    Amateur Blogger

  • Members
  • 150 posts
  • Playing:Ragnarok Online
  • Server:Thor

Posted 28 March 2016 - 05:05 AM

it's Lv94 with 930 SP, i had a problem with my homun when i tried using other AI config(cause it gives up its target if somebody KS'ed it so i tried some other AI), then it constantly crashed whenever i login my gene with homunculus. then one of the VMs/CMs helped me and posted an AI that works but one difference from the original is, it doesn't use auto caprice, so yeah haha now it still just auto attack(but now its the one who's KS'ing, i'm sorry haha) but no auto skill


  • 0

#175 Reaghann

Reaghann

    Amateur Blogger

  • Members
  • 347 posts
  • Playing:Ragnarok Online
  • Server:pRO New Chaos, iRO Thor

Posted 28 March 2016 - 10:12 AM

I've always been using Azzy AI in all my homunculi and never had a problem with Caprice. Have you tried tweaking the settings on Homunculus Tactics tab? Make sure the "Use Attack Skill" option is set to "Always".


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users