[Archived] Running Ragnarok Online on Windows Vista/Windows 7/Windows 8 - Page 7 - Ragnarok subforum archives - WarpPortal Community Forums

Jump to content


Photo

[Archived] Running Ragnarok Online on Windows Vista/Windows 7/Windows 8


  • Please log in to reply
236 replies to this topic

#151 Yomihime

Yomihime

    Awarded #1 Troll

  • Members
  • 638 posts
  • LocationWandering aimlessly in Ragnarok universe
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 25 August 2013 - 06:04 AM

Are you running the client in full-screen mode? The client doesn't work correctly when run in full-screen mode on Windows 8.

 

I am >_< Wow, that sucks I enjoy playing on full-screen mode D:


  • 0

#152 Squilly1

Squilly1

    I made it Off Topic

  • Members
  • 46 posts

Posted 31 August 2013 - 11:31 PM

Hello, a few weeks ago I encountered the "Sprite cannot be found/Sprite error" after one of the patches.  This is the first time that this has ever happened.  Don't play too much anymore but it pisses m off cuz it will pop up whenever someone passes with a sprite that is not recognized and I have to spam enter.  It is very annoying needless to say.  Uninstalled and reinstalled, so hoping it won't do this anymore but who knows...


  • 0

#153 rakuen303

rakuen303

    I am New.

  • Members
  • 1 posts

Posted 03 September 2013 - 06:04 AM

I download RO client: iRO-14.1.3-FullInstall-20121031-2012.msi

 

I installed it on Win7 32bit, and after it finished, i open the RAGNAROK.EXE and start downloading patch.

 

And when all the patch is download, on the login area, i can put my username and paswrd. but after that, it always failed connect to server.

 

What should i do?


Edited by rakuen303, 03 September 2013 - 06:46 AM.

  • 0

#154 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 03 September 2013 - 07:34 AM

I download RO client: iRO-14.1.3-FullInstall-20121031-2012.msi
 
I installed it on Win7 32bit, and after it finished, i open the RAGNAROK.EXE and start downloading patch.
 
And when all the patch is download, on the login area, i can put my username and paswrd. but after that, it always failed connect to server.
 
What should i do?


Where are you trying to connect from?
  • 0

#155 Estarra

Estarra

    I am New.

  • Members
  • 1 posts

Posted 05 September 2013 - 03:21 AM

Hello. 

I downloaded game, patched it and started to play. But time to time, when i push start button on the client, pops out some error window and then another queryRegionInfo window with "attempt to call nil value" written on it. And i cant close that window: neither "ok" button nor x helps. It's appears again and again. Task manager cant get rid of that thing either. Only  restart helps. But it's not very convenient. 

Thank you.


  • 0

#156 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 05 September 2013 - 10:30 PM

Hello. 

I downloaded game, patched it and started to play. But time to time, when i push start button on the client, pops out some error window and then another queryRegionInfo window with "attempt to call nil value" written on it. And i cant close that window: neither "ok" button nor x helps. It's appears again and again. Task manager cant get rid of that thing either. Only  restart helps. But it's not very convenient. 

Thank you.

 

This is an old issue. 

 

End-task the RO that's doing this, and prevent it in the future like this. 

 

 

 

There is no "solution" to the clientinfo issue (we would need a new patch client), but there is a simple workaround. That error is caused because the patcher doesn't correctly release it's lock on data.grf in time on some systems, so the game is unable to access it. The solution is to use the patcher to patch, but not to start the game.

Open your RO folder, rightclick ragexe.exe, and choose create shortcut.
Name the shortcut something informative, like Ragnarok - Bypass Patch
Rightclick the shortcut, and select Properties
On the Shortcut tab of properties, go to the Target field. You'll see something like:

"C:\Program Files\Gravity\Ragnarok Online\ragexe.exe"

At the end of the line, after the closing quote, add (space)-1rag1 like this:
"C:\Program Files\Gravity\Ragnarok Online\ragexe.exe" -1rag1


Now, when you want to patch the RO client (you should do this first), use the normal Ragnarok shortcut (run as admin as usual), but exit out of it when done, instead of clicking start.

Then start the client by using the shortcut you just created.

 


  • 0

#157 Shawl

Shawl

    I made it Off Topic

  • Members
  • 43 posts

Posted 10 September 2013 - 09:34 AM

Dr Azzy

 

 

I attempted to make the shortcut as you suggested but it still attempts to connect to the patch server... any ideas?


  • 0

#158 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 10 September 2013 - 10:37 AM

Dr Azzy

 

 

I attempted to make the shortcut as you suggested but it still attempts to connect to the patch server... any ideas?

 

When you run the shortcut I described making, it will not start the patcher at all. 

 

Did you point the shortcut at ragnarok.exe, instead of ragexe.exe? 


  • 0

#159 OniichanN

OniichanN

    Too Legit To Quit

  • Members
  • 1812 posts
  • LocationCroatia
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 13 September 2013 - 12:53 AM

Having some issues after the latest patch. When I run Ragnarok.exe it patches, but after I press play I get the following error: 

 

DAQReJJ.png

 

Found it's something related to DEP, added rag.exe to the list, tried the -1rag1, tried compatibility mode but still no dice. Anything else I can try? I'm on Windows 7 64 bit, ragnarok is installed on my D drive so there shouldn't be any conflicts with Windows.

 

EDIT:

Reinstalled, turned off firewall and antivirus, same thing. =/ Damn, my VIP is running and can't play. D:


Edited by OniichanN, 13 September 2013 - 01:13 AM.

  • 0

#160 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 13 September 2013 - 11:46 AM

Having some issues after the latest patch. When I run Ragnarok.exe it patches, but after I press play I get the following error: 
 
[…]
 
Found it's something related to DEP, added rag.exe to the list, tried the -1rag1, tried compatibility mode but still no dice. Anything else I can try? I'm on Windows 7 64 bit, ragnarok is installed on my D drive so there shouldn't be any conflicts with Windows.
 
EDIT:
Reinstalled, turned off firewall and antivirus, same thing. =/ Damn, my VIP is running and can't play. D:


Crashes are caused by programming errors in the client and therefore can ultimately only be fixed by the development team in South Korea. As someone who has been playing IRO sporadically since 2002, I can tell you that the development team unfortunately has an extremely poor record on fixing bugs in the client, regardless of their severity.

Unless you are willing to spend a large amount of time diagnosing the cause of this problem, then you'll have to run the client in either a sandbox or virtual machine for now.

You should submit the crash report created by the client to Gravity via the WarpPortal Support Center on the slim chance that it results in the problem being fixed by the development team. (Crash reports are saved somewhere in the client folder, and have the extension "dmp" or "dump".)

Edited by Axylus, 14 September 2013 - 07:03 AM.

  • 0

#161 Shawl

Shawl

    I made it Off Topic

  • Members
  • 43 posts

Posted 14 September 2013 - 06:52 PM

Azzy.

 

Yes I changed it to         C:\Ragnarok\Ragnarok.exe -1rag1         and it still attempts to patch?


  • 0

#162 Shawl

Shawl

    I made it Off Topic

  • Members
  • 43 posts

Posted 14 September 2013 - 07:36 PM

disregard, i got it! Thank you~~


  • 0

#163 yonkub

yonkub

    I am New.

  • Members
  • 3 posts

Posted 15 September 2013 - 02:28 AM

sir/mam can you help me.i cant access on the game when i open the launcher there  is a notification says [Windows cannot acces the specified device, path, or file. You may not have appropriate permission to access the item ] . im playing this before the last update. and when im trying to run the patch the notification appears like like that.


  • 0

#164 yonkub

yonkub

    I am New.

  • Members
  • 3 posts

Posted 15 September 2013 - 03:40 AM

im playing this game before the last maintenance and after the last aupdate and when  im trying to run the launcher and it's always failed, the notification appear like this        [ Windows cannot access the specified device, path, or file. You may not have the appropiate permission to access the item ]. i always run it as admin. Pls kindly help me this. thanks             


  • 0

#165 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 15 September 2013 - 05:59 AM

im playing this game before the last maintenance and after the last aupdate and when  im trying to run the launcher and it's always failed, the notification appear like this        [ Windows cannot access the specified device, path, or file. You may not have the appropiate permission to access the item ]. i always run it as admin. Pls kindly help me this. thanks


Are you playing Ragnarök Online or Ragnarök Online 2? This is the Ragnarök Online section of the forum.
  • 0

#166 Shawl

Shawl

    I made it Off Topic

  • Members
  • 43 posts

Posted 16 September 2013 - 11:58 AM

OK new Question, Why when I load the main client (patch) I have to wait for it to install updates from 2011 to present.. I think I have asked before but did not receive a response.. any suggestions?


  • 0

#167 Shawl

Shawl

    I made it Off Topic

  • Members
  • 43 posts

Posted 18 September 2013 - 02:19 PM

Bump


  • 0

#168 OniichanN

OniichanN

    Too Legit To Quit

  • Members
  • 1812 posts
  • LocationCroatia
  • Playing:Ragnarok Online
  • Server:Chaos

Posted 23 September 2013 - 01:42 AM

You did get a response for it mate. :) Here

 

For the patch from 2011 thing, I solved it by editing the patch.inf file with a hex editor. Reinstalling RO, updating and then making backups of the files like Axylus suggested in your thread should work.

 

As for my problem that was mentioned, uninstalling (NOT just disabling) the antivirus helped. I tried both avast and bitdefender, both caused problems (the avast tip didn't work in my case D: ). Now I'm searching for an AV that doesn't stop RO from working. Will update once/if I find anything.

 

EDIT:

NOD32 is working. No problems since the day I installed it.


Edited by OniichanN, 07 October 2013 - 02:05 AM.

  • 0

#169 LBH4U

LBH4U

    I made it Off Topic

  • Members
  • 12 posts
  • Playing:Ragnarok Online 2

Posted 25 September 2013 - 05:57 AM

I downloaded the installer program and when I try to run it I get the error message that it's not a "valid Win32 Application".  Any advice would be appreciated.  I am running Vista 32bit.


Edited by LBH4U, 25 September 2013 - 06:05 AM.

  • 0

#170 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 25 September 2013 - 09:04 AM

I downloaded the installer program and when I try to run it I get the error message that it's not a "valid Win32 Application".  Any advice would be appreciated.  I am running Vista 32bit.

 

Um, what is the file name of the installer?


  • 0

#171 DrAzzy

DrAzzy

    Really Azzy? Already?

  • VMod Retired
  • 15606 posts
  • LocationNew England
  • Playing:Ragnarok Online
  • Server:Chaos-Clandestine Society

Posted 25 September 2013 - 10:42 AM

Um, what is the file name of the installer?

And where was it downloaded from?

 

And for that matter, what's the size of the installer? (rightclick -> properties, and it'll show size. We want size, not size on disk)


  • 0

#172 tygortora

tygortora

    I am New.

  • Members
  • 1 posts
  • Playing:Nothing

Posted 06 October 2013 - 04:05 PM

I don't know if it's my computer, my OS (Windows 7), or some other issue, but I just installed the game and went through the patching with no problem only for the "Ragnarok Setup" window to prevent me from playing the game.

 

I check the boxes I want on the "Option" tab and set everything on the "System" tab, then click "OK". I get another, smaller window asking "Do you want to save this setup?" and then I click "OK". Both close, but then the innitial "Ragnarok Setup" window pops up again. I did this four times, then rebooted and tried again to make sure it wasn't just a fluke. But I keeps doing the same thing and it's keeping me from playing the game. I can't even just close out by clicking the "X" (close) button or click "Cancel" because it still just closes and pops up again. I have to shut down or reboot my computer before it will stay closed.

 

If anyone has an idea on what could be causing this or how to fix it, I would greatly appreciate some advice.


Edited by tygortora, 06 October 2013 - 05:37 PM.

  • 0

#173 Axylus

Axylus

    Too Legit To Quit

  • Members
  • 2383 posts
  • LocationEngland, United Kingdom

Posted 07 October 2013 - 12:55 AM

I don't know if it's my computer, my OS (Windows 7), or some other issue, but I just installed the game and went through the patching with no problem only for the "Ragnarok Setup" window to prevent me from playing the game.

 

I check the boxes I want on the "Option" tab and set everything on the "System" tab, then click "OK". I get another, smaller window asking "Do you want to save this setup?" and then I click "OK". Both close, but then the innitial "Ragnarok Setup" window pops up again. I did this four times, then rebooted and tried again to make sure it wasn't just a fluke. But I keeps doing the same thing and it's keeping me from playing the game. I can't even just close out by clicking the "X" (close) button or click "Cancel" because it still just closes and pops up again. I have to shut down or reboot my computer before it will stay closed.

 

If anyone has an idea on what could be causing this or how to fix it, I would greatly appreciate some advice.

 

See the 2nd post in this thread.


  • 0

#174 Vonita

Vonita

    Amateur Blogger

  • Members
  • 105 posts
  • LocationPhilippines
  • Playing:Ragnarok Online

Posted 17 October 2013 - 07:52 AM

I just downloaded the IRO full client yesterday and I'm stuck! at this patching stage. Can anyone please help me?

 

 

2d8j0rc.jpg


  • 0

#175 JuliaBrisbane

JuliaBrisbane

    I am New.

  • Members
  • 1 posts

Posted 26 October 2013 - 08:10 PM

I have a problem. I installed RO and got past the patch process, where my problem is that I can't get past the Ragnarok Setup screen. No matter what res i put it at and click ok. The screen keeps popping back up. I have to go to the task manager to end the process to get the setup screen off my screen. I am using win 7 pro. Is this fixable? This is using Ragnarok. Using Ragnarok Classic I get the same problem except it doesn't show up in the processes list of the task manager and I have to restart the computer to get the setup screen off the screen. 


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users